码迷,mamicode.com
首页 > Web开发 > 详细

ZOJ QS Network (prime_裸题)

时间:2015-08-17 12:03:17      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS‘s have received the message.

A sample is shown below:

技术分享


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS‘s favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS‘s favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370


prime算法裸题。。。

下面附上代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define inf 99999999
using namespace std;

int map[1010][1010],vis[1010],lowcost[1010],p[1010];
int main()
{
	int t,n,i,j,k,sum,w;
	while(scanf("%d",&t)!=EOF){
		while(t--) {
			scanf("%d",&n);
			for(i=1;i<=n;i++) {
				cin>>p[i];
				vis[i]=0;
			}
			for(i=1;i<=n;i++) {
				for(j=1;j<=n;j++) {
					cin>>w;
					w=w+p[i]+p[j];
					map[i][j]=inf;
					if(i!=j) map[i][j]=w;
				}
			}
			k=-1;
			sum=0;
			vis[1]=1;
			for(i=1;i<=n;i++) lowcost[i]=map[1][i];
			for(i=1;i<=n;i++) {
				int temp=inf;
				for(j=1;j<=n;j++) {
					if(!vis[j] && lowcost[j]<temp) {
						k=j;
						temp=lowcost[j];
					}
				}
				if(temp==inf) break;
				vis[k]=1;
				sum+=temp;
				for(j=1;j<=n;j++) {
					if(!vis[j] && lowcost[j]>map[k][j]) {
						lowcost[j]=map[k][j];
					}
				}
			}
			printf("%d\n",sum);
		}
	}
	return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

ZOJ QS Network (prime_裸题)

标签:

原文地址:http://blog.csdn.net/h1021456873/article/details/47722829

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!