码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 题目1743 Musical Theme(后缀数组,求一个串中最长不重叠重复子串)

时间:2015-08-18 14:14:55      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:

Musical Theme
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 21826   Accepted: 7467

Description

A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1..88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this programming task is about notes and not timings.
Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it:
  • is at least five notes long
  • appears (potentially transposed -- see below) again somewhere else in the piece of music
  • is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)

Transposed means that a constant positive or negative value is added to every note value in the theme subsequence.
Given a melody, compute the length (number of notes) of the longest theme.
One second time limit for this problem‘s solutions!

Input

The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes.
The last test case is followed by one zero.

Output

For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.

Sample Input

30
25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
82 78 74 70 66 67 64 60 65 80
0

Sample Output

5

Hint

Use scanf instead of cin to reduce the read time.

Source

LouTiancheng@POJ

题目大意:

问一个串中长度大于5的,不重叠重复的子串,一个串任意加或减同一个数形成串也算重复,问最长的

思路:让这个串的每两个值之间两两相减,因为可能有负的的,所有值都在1~88之间,所以加上90,范围肯定在200以内,当两个子串的最长公共前缀大于k且两个串的起点差大于k的话,肯定存在大于k的不重叠重复的串,所以用后缀数组二分长度就好

ac代码

Problem: 1743  User: kxh1995 
Memory: 680K  Time: 250MS 
Language: C++  Result: Accepted 

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
int s[20020];
int sa[20020],t1[20020],t2[20020],c[20020];
int rank[20020],height[20020];
void build_sa(int s[],int n,int m)
{
	int i,j,p,*x=t1,*y=t2;
	for(i=0;i<m;i++)
		c[i]=0;
	for(i=0;i<n;i++)
		c[x[i]=s[i]]++;
	for(i=1;i<m;i++)
		c[i]+=c[i-1];
	for(i=n-1;i>=0;i--)
		sa[--c[x[i]]]=i;
	for(j=1;j<=n;j<<=1)
	{
		p=0;
		for(i=n-j;i<n;i++)
			y[p++]=i;
		for(i=0;i<n;i++)
			if(sa[i]>=j)
				y[p++]=sa[i]-j;
		for(i=0;i<m;i++)
			c[i]=0;
		for(i=0;i<n;i++)
			c[x[y[i]]]++;
		for(i=1;i<m;i++)
			c[i]+=c[i-1];
		for(i=n-1;i>=0;i--)
			sa[--c[x[y[i]]]]=y[i];
		swap(x,y);
		p=1;
		x[sa[0]]=0;
		for(i=1;i<n;i++)
			x[sa[i]]=y[sa[i-1]]==y[sa[i]]&&y[sa[i-1]+j]==y[sa[i]+j]?p-1:p++;
		if(p>=n)
			break;
		m=p;
	}
}
void getHeight(int s[],int n)
{
	int i,j,k=0;
	for(i=0;i<=n;i++)
		rank[sa[i]]=i;
	for(i=0;i<n;i++)
	{
		if(k)
			k--;
		j=sa[rank[i]-1];
		while(s[i+k]==s[j+k])
			k++;
		height[rank[i]]=k;
	}
}
int check(int n,int k)
{
	int maxn=sa[1],minn=sa[1];
	for(int i=2;i<n;i++)
	{
		if(height[i]<k)
			maxn=minn=sa[i];
		else
		{
			if(maxn<sa[i])
				maxn=sa[i];
			if(minn>sa[i])
				minn=sa[i];
			if(maxn-minn>k)
				return 1;
		}
	}
	return 0;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF,n)
	{
		int i;
		for(i=0;i<n;i++)
		{
			scanf("%d",&s[i]);
		}
		for(i=n-1;i>0;i--)
			s[i]=s[i]-s[i-1]+90;
		n--;
		for(i=0;i<n;i++)
			s[i]=s[i+1];
		build_sa(s,n+1,200);
		getHeight(s,n);
		int ans=-1;
		int l=1,r=n/2;
		while(l<=r)
		{
			int mid=(l+r)>>1;
			if(check(n,mid))
			{
				ans=mid;
				l=mid+1;
			}
			else
				r=mid-1;
		}
	//	printf("%d\n",ans);
		if(ans<4)
			printf("0\n");
		else
			printf("%d\n",ans+1);
	}
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 题目1743 Musical Theme(后缀数组,求一个串中最长不重叠重复子串)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/47750125

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!