码迷,mamicode.com
首页 > Windows程序 > 详细

hdoj 1509 Windows Message Queue

时间:2015-08-18 16:16:43      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:windows message queu   hdoj 1509   优先队列   队列   hdoj   

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4557    Accepted Submission(s): 1819


Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 

Input
There‘s only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there‘re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there‘s no message in the queue, output "EMPTY QUEUE!". There‘s no output for "PUT" command.
 

Sample Input
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET
 

Sample Output
EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!
/*
本题大意:
短信有不同的优先级,参数,及msg,读取短信按照优先级读取,优先级相同,按照输入的顺序读 
*/
#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
struct qu
{
	int key;//输入的顺序 
	int yxj;//优先级 
	int num;//参数 
	char name[100];//短信中的字符 
    friend bool operator < (qu a,qu b)//优先队列,按排序方式 进行(前面的题意) 
	{
		if(a.yxj ==b.yxj )
		return a.key>b.key;
		return a.yxj>b.yxj;
	}
};
int main()
{
	int i,j,k=0;
	char s[100];
	qu lw;
	priority_queue<qu>q;
	while(scanf("%s",s)!=EOF)
	{
		if(s[0]=='G')
		{
			if(q.empty() )
			printf("EMPTY QUEUE!\n");
			else 
			{
				lw=q.top() ;
				printf("%s %d\n",lw.name ,lw.num );
				q.pop() ;
			}
		}
		else
		{
			scanf("%s%d%d",lw.name,&lw.num,&lw.yxj);
			lw.key =k++;
			q.push(lw);
		}
	}
	return 0;
} 

 



版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj 1509 Windows Message Queue

标签:windows message queu   hdoj 1509   优先队列   队列   hdoj   

原文地址:http://blog.csdn.net/zhangxiaoxiang123/article/details/47753105

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!