码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 题目3261 Milk Patterns(后缀数组求最长重叠至少k次的子串长度)

时间:2015-08-18 19:18:24      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:

Milk Patterns
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 12128   Accepted: 5387
Case Time Limit: 2000MS

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can‘t predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ KN) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers: N and K
Lines 2..N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

Source

USACO 2006 December Gold

ac代码

Problem: 3261  User: kxh1995 
Memory: 680K  Time: 47MS 
Language: C++  Result: Accepted 
#include<stdio.h>   
#include<string.h>   
#include<algorithm>   
#include<iostream>   
using namespace std;  
int s[20020];  
int sa[20020],t1[20020],t2[20020],c[20020];  
int rank[20020],height[20020];  
void build_sa(int s[],int n,int m)  
{  
    int i,j,p,*x=t1,*y=t2;  
    for(i=0;i<m;i++)  
        c[i]=0;  
    for(i=0;i<n;i++)  
        c[x[i]=s[i]]++;  
    for(i=1;i<m;i++)  
        c[i]+=c[i-1];  
    for(i=n-1;i>=0;i--)  
        sa[--c[x[i]]]=i;  
    for(j=1;j<=n;j<<=1)  
    {  
        p=0;  
        for(i=n-j;i<n;i++)  
            y[p++]=i;  
        for(i=0;i<n;i++)  
            if(sa[i]>=j)  
                y[p++]=sa[i]-j;  
        for(i=0;i<m;i++)  
            c[i]=0;  
        for(i=0;i<n;i++)  
            c[x[y[i]]]++;  
        for(i=1;i<m;i++)  
            c[i]+=c[i-1];  
        for(i=n-1;i>=0;i--)  
            sa[--c[x[y[i]]]]=y[i];  
        swap(x,y);  
        p=1;  
        x[sa[0]]=0;  
        for(i=1;i<n;i++)  
            x[sa[i]]=y[sa[i-1]]==y[sa[i]]&&y[sa[i-1]+j]==y[sa[i]+j]?p-1:p++;  
        if(p>=n)  
            break;  
        m=p;  
    }  
}  
void getHeight(int s[],int n)  
{  
    int i,j,k=0;  
    for(i=0;i<=n;i++)  
        rank[sa[i]]=i;  
    for(i=0;i<n;i++)  
    {  
        if(k)  
            k--;  
        j=sa[rank[i]-1];  
        while(s[i+k]==s[j+k])  
            k++;  
        height[rank[i]]=k;  
    }  
}  
int judge(int n,int k,int len)
{
	int num=1;
	for(int i=1;i<=n;i++)
	{
		if(height[i]>=len)
		{
			num++;
			if(num>=k)
				return 1;
		}
		else
			num=1;
	}
	return 0;
}
int main()
{
	int n,k;
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		int i;
		int num=-1;
		for(i=0;i<n;i++)
		{
			scanf("%d",&s[i]);
			if(num<s[i])
				num=s[i];
		}
		s[n]=0;
		build_sa(s,n+1,num+1);
		getHeight(s,n);
		int ans=0;
		int l=0,r=n;
		while(l<=r)
		{
			int mid=(l+r)>>1;
			if(judge(n,k,mid))
			{
				ans=mid;
				l=mid+1;
			}
			else
				r=mid-1;
		}
		printf("%d\n",ans);
	}
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 题目3261 Milk Patterns(后缀数组求最长重叠至少k次的子串长度)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/47756337

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!