码迷,mamicode.com
首页 > 编程语言 > 详细

SPOJ 题目694 Distinct Substrings(后缀数组,求不同的子串个数)

时间:2015-08-18 22:48:38      阅读:154      评论:0      收藏:0      [点我收藏+]

标签:

DISUBSTR - Distinct Substrings

no tags 

Given a string, we need to find the total number of its distinct substrings.

Input

T- number of test cases. T<=20;
Each test case consists of one string, whose length is <= 1000

Output

For each test case output one number saying the number of distinct substrings.

Example

Sample Input:
2
CCCCC
ABABA

Sample Output:
5
9

Explanation for the testcase with string ABABA: 
len=1 : A,B
len=2 : AB,BA
len=3 : ABA,BAB
len=4 : ABAB,BABA
len=5 : ABABA

Thus, total number of distinct substrings is 9.

技术分享

ac代码

#include<stdio.h>      
#include<string.h>      
#include<algorithm>      
#include<iostream>      
using namespace std;    
int s[2002];   
char str[2002]; 
int sa[2002],t1[2002],t2[2002],c[2002];    
int rank[2002],height[2002];    
void build_sa(int s[],int n,int m)    
{    
    int i,j,p,*x=t1,*y=t2;    
    for(i=0;i<m;i++)    
        c[i]=0;    
    for(i=0;i<n;i++)    
        c[x[i]=s[i]]++;    
    for(i=1;i<m;i++)    
        c[i]+=c[i-1];    
    for(i=n-1;i>=0;i--)    
        sa[--c[x[i]]]=i;    
    for(j=1;j<=n;j<<=1)    
    {    
        p=0;    
        for(i=n-j;i<n;i++)    
            y[p++]=i;    
        for(i=0;i<n;i++)    
            if(sa[i]>=j)    
                y[p++]=sa[i]-j;    
        for(i=0;i<m;i++)    
            c[i]=0;    
        for(i=0;i<n;i++)    
            c[x[y[i]]]++;    
        for(i=1;i<m;i++)    
            c[i]+=c[i-1];    
        for(i=n-1;i>=0;i--)    
            sa[--c[x[y[i]]]]=y[i];    
        swap(x,y);    
        p=1;    
        x[sa[0]]=0;    
        for(i=1;i<n;i++)    
            x[sa[i]]=y[sa[i-1]]==y[sa[i]]&&y[sa[i-1]+j]==y[sa[i]+j]?p-1:p++;    
        if(p>=n)    
            break;    
        m=p;    
    }    
}    
void getHeight(int s[],int n)    
{    
    int i,j,k=0;    
    for(i=0;i<=n;i++)    
        rank[sa[i]]=i;    
    for(i=0;i<n;i++)    
    {    
        if(k)    
            k--;    
        j=sa[rank[i]-1];    
        while(s[i+k]==s[j+k])    
            k++;    
        height[rank[i]]=k;    
    }    
}    
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int i;
		scanf("%s",str);
		int len=strlen(str);
		for(i=0;i<len;i++)
		{
			s[i]=str[i];
		}
		s[len]=0;
		build_sa(s,len+1,128);
		getHeight(s,len);
		long long ans=(len)*(len+1)/2;
		for(i=1;i<=len;i++)
		{
			ans-=height[i];
		}
		printf("%lld\n",ans);
	}
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

SPOJ 题目694 Distinct Substrings(后缀数组,求不同的子串个数)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/47760747

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!