码迷,mamicode.com
首页 > 编程语言 > 详细

Genealogical tree POJ 2367【拓扑排序】

时间:2015-08-18 22:56:35      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=2367

Genealogical tree


Special Judge
Problem Description
The system of Martians‘ blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there‘s nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.
 

Input
The first line of the standard input contains an only number N, 1 <= N <= 100 a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member‘s children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.
 

Output
The standard output should contain in its only line a sequence of speakers‘ numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.
 

Sample Input
5 0 4 5 1 0 1 0 5 3 0 3 0
 

Sample Output
2 4 5 3 1
 

由于是special判断,答案不唯一
//方法一 

#include<cstdio>
#include<cstring>
#include<queue>
#define N 110
using namespace std;
int n;
int relate[N][N];
int indegree[N];
int res[N];
void topo_sort()
{
	
	int i,j;
	int flag=1;
	for(j=1;j<=n;++j) 
	{
		int temp=-1;
		for(i=1;i<=n;++i)
		{
			if(indegree[i]==0)
			{
				temp=i;
				break;
			}		
		}
		indegree[temp]=-1;
		flag?printf("%d",temp):printf(" %d",temp);
		flag=0;
		for(i=1;i<=n;++i)
		{
			if(relate[temp][i])
			{
				indegree[i]--;
			}
		}
	}
	puts("");
}
int main()
{
	int tmp,m;
	int i,j;
	while(~scanf("%d",&n))
	{
		memset(indegree,0,sizeof(indegree));
		memset(relate,0,sizeof(relate));
		for(i=1;i<=n;++i)
		{
			while(~scanf("%d",&m),m)						
			{
				relate[i][m]=1;
				indegree[m]++;
			}
				
		}
		topo_sort();
	}
	return 0;
}

//邻接表
//方法二
#include<cstdio>
#include<cstring>
#include<queue>
#define N 110
using namespace std;
int n;
int relate[N][N];
int indegree[N];
int res[N];
void topo_sort()
{
	priority_queue<int>q;
	int i,j;
	for(i=1;i<=n;++i)
	{
		if(indegree[i]==0)
		{
			q.push(i);
		}		
	}
	j=0;
	while(!q.empty())
	{
		int u=q.top();
		q.pop();
		res[j++]=u;
		for(i=1;i<=n;++i)
		{
			if(relate[u][i])
			{
				indegree[i]--;
				if(indegree[i]==0)
				{
					q.push(i);
				}	
			}
		}
	}
	for(i=j-1;i>=0;--i)
		printf("%d ",res[i]);
	printf("\n");
}
int main()
{
	int tmp,m;
	int i,j;
	while(~scanf("%d",&n))
	{
		memset(indegree,0,sizeof(indegree));
		memset(relate,0,sizeof(relate));
		for(i=1;i<=n;++i)
		{
			while(~scanf("%d",&m),m)						
			{
				relate[m][i]=1;
				indegree[i]++;
			}
				
		}
		topo_sort();
	}
	return 0;
} 


版权声明:本文为博主原创文章,未经博主允许不得转载。

Genealogical tree POJ 2367【拓扑排序】

标签:

原文地址:http://blog.csdn.net/yuzhiwei1995/article/details/47759631

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!