码迷,mamicode.com
首页 > 编程语言 > 详细

HDU - 4712 Hamming Distance(坑爹的随机数算法 + 暴力求解)

时间:2015-08-19 20:45:43      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:

Hamming Distance

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1728    Accepted Submission(s): 680


Problem Description
(From wikipedia) For binary strings a and b the Hamming distance is equal to the number of ones in a XOR b. For calculating Hamming distance between two strings a and b, they must have equal length.
Now given N different binary strings, please calculate the minimum Hamming distance between every pair of strings.
 

Input
The first line of the input is an integer T, the number of test cases.(0<T<=20) Then T test case followed. The first line of each test case is an integer N (2<=N<=100000), the number of different binary strings. Then N lines followed, each of the next N line is a string consist of five characters. Each character is ‘0‘-‘9‘ or ‘A‘-‘F‘, it represents the hexadecimal code of the binary string. For example, the hexadecimal code "12345" represents binary string "00010010001101000101".
 

Output
For each test case, output the minimum Hamming distance between every pair of strings.
 

Sample Input
2 2 12345 54321 4 12345 6789A BCDEF 0137F
 

Sample Output
6 7
我想对出题的人说一句话,坑爹的题目,坑爹随机算法
技术分享
其中可能提交会出现错误,但是多提交几次就对了(建议大家该为1e6就可以了)
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <cstdio>
#include <string>
#include <ctime>
using namespace std;
typedef long long LL;
const int MAXN = 1e5 + 5;
const int INF = 0x3f3f3f3f;
int T, n;
int A[MAXN];
int Get_Num(int m) {
    int ret = 0;
    while(m) {
        ret += (m & 1);
        m >>= 1;
    }
    return ret;
}
int main() {
    scanf("%d", &T);
    while(T --) {
        scanf("%d", &n);
        for(int i = 0; i < n; i ++) {
            scanf("%X", &A[i]);
        }
        srand(time(NULL));
        int  Min = INF;
        for(int i = 0; i < 1e5; i ++) {
            int a = rand() % n;
            int b = rand() % n;
            if(a == b) continue;
            Min = min(Min, Get_Num(A[a] ^ A[b]));
        }
        printf("%d\n",Min);
    }
    return 0;
}



 

版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU - 4712 Hamming Distance(坑爹的随机数算法 + 暴力求解)

标签:

原文地址:http://blog.csdn.net/qq_18661257/article/details/47783325

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!