码迷,mamicode.com
首页 > 数据库
MySQL LIST分区
介绍 LIST分区和RANGE分区非常的相似,主要区别在于LIST是枚举值列表的集合,RANGE是连续的区间值的集合。二者在语法方面非常的相似。同样建议LIST分区列是非null列,否则插入null值如果枚举列表里面不存在null值会插入失败,这点和其它的分区不一样,RANGE分区会将其作为最小分区 ...
分类:数据库   时间:2016-11-04 20:46:33    阅读次数:222
Mysql的存储引擎介绍
下面主要介绍InnoDB、MyISAM和MEMEORY三种存储引擎。 InnoDB存储引擎 InnoDB遵循CNU通用公开许可(GPL)发行。InnoDB已经被一些重量级互联网公司所采用,如雅虎、Slashdot和Google,为用户操作非常大的数据库提供了一个强大的解决方案。InnoDB给MySQ ...
分类:数据库   时间:2016-11-04 20:46:34    阅读次数:248
UE4数据库中文乱码问题
解决乱码问题: 中文乱码无非就是编码格式问题。MySQL现在默认都是UTF8编码。 第一:在mysql_real_connect后,程序中设置编码为mysql_set_character_set(mysql, "utf8");【可能有人问,MySQL不是默认UTF8吗?为什么还要设置?sorry,就 ...
分类:数据库   时间:2016-11-04 20:45:53    阅读次数:1279
FMDB的使用
...
分类:数据库   时间:2016-11-04 20:39:01    阅读次数:247
CentOS7下安装配置MariaDB
参考: http://www.2cto.com/os/201504/394141.html http://outofmemory.cn/code-snippet/2533/mysql-create-database-specify-utf-8-coding https://mariadb.com/k ...
分类:数据库   时间:2016-11-04 20:30:23    阅读次数:254
mysql-netstat
TCP状态转移要点TCP协议规定,对于已经建立的连接,网络双方要进行四次握手才能成功断开连接,如果缺少了其中某个步骤,将会使连接处于假死状态,连接本身占用的资源不 会被释放。网络服务器程序要同时管理大量连接,所以很有必要保证无用连接完全断开,否则大量僵死的连接会浪费许多服务器资源。在众多TCP状态中 ...
分类:数据库   时间:2016-11-04 20:23:28    阅读次数:180
MYSQL提权方法
cve-2016-6662 MYSQL提权分析 将exp先写入tmp目录,并编译成so文件,需要修改一下ip,port和my.cnf的位置 发现可写的my.cnf会被忽略???不知道为什么(难道打补丁了?),不知道5.5的情况会怎么样,所以先把my.cnf的权限改回来744 文章转发至:http:/ ...
分类:数据库   时间:2016-11-04 20:23:47    阅读次数:290
【MYSQL】数据类型
原文 泪云山海的博客 mysql 数据类型 1、整型 取值范围如果加了unsigned,则最大值翻倍,如tinyint unsigned的取值范围为(0~256)。 int(m)里的m是表示SELECT查询结果集中的显示宽度,并不影响实际的取值范围,没有影响到显示的宽度,不知道这个m有什么用。 2、 ...
分类:数据库   时间:2016-11-04 20:09:48    阅读次数:193
mongoDB学习
"不知道为什么,就是想写一篇文章。。。"——某程序员 一直在说要学习mongoDB,前段时间终于学习了。今天刚好把mongo和nodeJS结合起来了,就写一篇文章总结一下。 先说一下mongoDB的安装,在mongo官网下载安装包(自行百度),或者在GitHub上面自行下载然后编译(过程省略。。。) ...
分类:数据库   时间:2016-11-04 20:03:30    阅读次数:247
Access restriction: The type QName is not accessible due to restriction on required library
There's another solution that also works. I found it on this forum: This works because you have multiple classes in different jar files. Removing and ...
分类:数据库   时间:2016-11-04 19:56:07    阅读次数:248
【转载】【Centos linux系统】命令行(静默)安装oracle 11gR2
【原文】:http://blog.chinaunix.net/uid-23886490-id-3565998.html 一.安装前准备 1.内存及swap要求 至于swap如何添加,后文将提到 2.硬盘空间 3.修改主机名,及ip对应关系 4.关闭Selinux 5.下载oracle11gR2 官网 ...
分类:数据库   时间:2016-11-04 19:51:40    阅读次数:327
解决Mysql连接池被关闭 ,hibernate尝试连接不能连接的问题。 (默认mysql连接池可以访问的时间为8小时,如果超过8小时没有连接,mysql会自动关闭连接池。系统发布第二天访问链接关闭问题。
解决Mysql连接池被关闭 ,hibernate尝试连接不能连接的问题。 (默认MySQL连接池可以访问的时间为8小时,如果超过8小时没有连接,mysql会自动关闭连接池。 所以系统发布第二天访问会失去链接,导致访问失败。因此稳定解决办法是把hibernate默认的连接池换成c3p0链接池。 在Hi ...
分类:数据库   时间:2016-11-04 19:43:01    阅读次数:306
GTID及mysql-proxy实现mysql5.6读写分离
GTID说明:MySQL5.6引入的GTID(GlobalTransactionIDs)使得其复制功能的配置、监控及管理变得更加易于实现,且更加健壮。要在MySQL5.6中使用复制功能,其服务配置段[mysqld]中于少应该定义如下选项: binlog-format:二进制日志的格式,有row、statement和mixed几种类型; 用于..
分类:数据库   时间:2016-11-04 18:03:17    阅读次数:282
MYsql常用的数据类型
字符型数据类型常用的字符型有两,一种是CHAR为不可变数值类型和一种可变的数据类型VARECHAR。什么意思呢?具体来说CHAR和VARECHAR有以下两种区别。首先固定长度类型相比于可变数据的VARECHAR来说而执行效率更高,更加快速。另一点不可变类型可以创建索引而可变类型则不可以创..
分类:数据库   时间:2016-11-04 17:56:08    阅读次数:208
zabbix自动发现mysql端口并监控
一、需求:因为我们是游戏业务,要用到mysql,一个服务器上面跑多个mysql实例也是很正常。如果单独手动一台台修改agent.conf,添加web监控,太费时费力。所以就想的要用zabbix的自动发现来监控二、配置Agent1.编写自动发现端口脚本[root@test~]#cat/etc/zabbix/alertscripts/za..
分类:数据库   时间:2016-11-04 17:55:46    阅读次数:264
基于Centos6.5的MySQL5.7.15二进制源码安装
操作系统准备,本次mysql5.7实战安装是在Centos6.5x86_64系统上完成。如下是系统详情。[root@mysqlserver~]#uname-a Linuxmysqlserver2.6.32-431.el6.x86_64#1SMPFriNov2203:15:09UTC2013x86_64x86_64x86_64GNU/Linux [root@mysqlserver~]#cat/etc/redhat-release CentOSreleas..
分类:数据库   时间:2016-11-04 17:52:34    阅读次数:234
SQL Server超时诊断和调优
SQLServer超时诊断和调优一、超时分析下面是用户访问一个Web站点的常见错误:详细错误描述如下:[SqlException(0x80131904):Timeoutexpired.Thetimeoutperiodelapsedpriortocompletionoftheoperationortheserverisnotresponding.]System.Data.SqlClient.SqlConnection.OnError(..
分类:数据库   时间:2016-11-04 17:47:01    阅读次数:310
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!