码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 2734 Exchange Cards

时间:2015-08-20 20:55:30      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:exchange cards   zoj 2734   zoj   搜索   

 

Exchange Cards

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) :   Accepted Submission(s) : 
Problem Description
As a basketball fan, Mike is also fond of collecting basketball player cards. But as a student, he can not always get the money to buy new cards, so sometimes he will exchange with his friends for cards he likes. Of course, different cards have different value, and Mike must use cards he owns to get the new one. For example, to get a card of value 10$, he can use two 5$ cards or three 3$ cards plus one 1$ card, depending on the kinds of cards he have and the number of each kind of card. And Sometimes he will involve unfortunately in a bad condition that he has not got the exact value of the card he is looking for (fans always exchange cards for equivalent value).

Here comes the problem, given the card value he plans to get and the cards he has, Mike wants to fix how many ways he can get it. So it‘s you task to write a program to figure it out.

Input

The problem consists of multiple test cases, terminated by EOF. There‘s a blank line between two inputs.

The first line of each test case gives n, the value of the card Mike plans to get and m, the number of different kinds of cards Mike has. n will be an integer number between 1 and 1000. m will be an integer number between 1 and 10.

The next m lines give the information of different kinds of cards Mike have. Each line contains two integers, val and num, representing the value of this kind of card, and the number of this kind of card Mike have.

Note: different kinds of cards will have different value, each val and num will be an integer greater than zero.

Output

For each test case, output in one line the number of different ways Mike could exchange for the card he wants. You can be sure that the output will fall into an integer value.

Output a blank line between two test cases.

Sample Input

5 2
2 1
3 1

10 5
10 2
7 2
5 3
2 2
1 5

Sample Output

1

7
dfs即可:
#include<stdio.h>
#include<string.h>
int val,n,ans,sum;
int num[1010];
void dfs(int x)
{
	int i;
	if(sum==val)//达到价值ans++ 
	{
		ans++;
		return ;
	}
	for(i=x;i<=val;i++)
	{
		if(num[i]&&sum+i<=val)//i价值的卡片有剩余 ,且没有达到val的大小 
		{
			num[i]--;
			sum+=i;
			dfs(i); 
			sum-=i;
			num[i]++;
		}
	}
}
int main()
{
	int bl=0;
	while(scanf("%d%d",&val,&n)!=EOF)
	{
		if(bl)
		printf("\n");
		bl++;
		int x,y;
		ans=sum=0;
		memset(num,0,sizeof(num));
	   while(n--)
	   {
	   	scanf("%d%d",&x,&y);
	   	num[x]=y;
	   }
	   dfs(1);
	   printf("%d\n",ans);
	}
	return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

zoj 2734 Exchange Cards

标签:exchange cards   zoj 2734   zoj   搜索   

原文地址:http://blog.csdn.net/zhangxiaoxiang123/article/details/47813923

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!