码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5328(Problem Killer-暴力)

时间:2015-08-20 20:56:40      阅读:221      评论:0      收藏:0      [点我收藏+]

标签:

Problem Killer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1535    Accepted Submission(s): 576


Problem Description
You are a "Problem Killer", you want to solve many problems.
Now you have n技术分享 problems, the i技术分享-th problem‘s difficulty is represented by an integer a技术分享i技术分享技术分享 (1a技术分享i技术分享10技术分享9技术分享技术分享).
For some strange reason, you must choose some integer l技术分享 and r技术分享 (1lrn技术分享), and solve the problems between the l技术分享-th and the r技术分享-th, and these problems‘ difficulties must form an AP (Arithmetic Progression) or a GP (Geometric Progression).
So how many problems can you solve at most?

You can find the definitions of AP and GP by the following links:
https://en.wikipedia.org/wiki/Arithmetic_progression
https://en.wikipedia.org/wiki/Geometric_progression
 

Input
The first line contains a single integer T技术分享, indicating the number of cases.
For each test case, the first line contains a single integer n技术分享, the second line contains n技术分享 integers a技术分享1技术分享,a技术分享2技术分享,?,a技术分享n技术分享技术分享.

T10技术分享4技术分享,n10技术分享6技术分享技术分享
 

Output
For each test case, output one line with a single integer, representing the answer.
 

Sample Input
2 5 1 2 3 4 6 10 1 1 1 1 1 1 2 3 4 5
 

Sample Output
4 6
 

Author
XJZX
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:  5416 5415 5414 5413 5412 
 


暴力



#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cctype>
#include<ctime>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define RepD(i,n) for(int i=n;i>=0;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
#define Forpiter(x) for(int &p=iter[x];p;p=next[p])  
#define Lson (x<<1)
#define Rson ((x<<1)+1)
#define MEM(a) memset(a,0,sizeof(a));
#define MEMI(a) memset(a,127,sizeof(a));
#define MEMi(a) memset(a,128,sizeof(a));
#define INF (2139062143)
#define F (100000007)
#define MAXN (1000000+10)
typedef long long ll;
ll mul(ll a,ll b){return (a*b)%F;}
ll add(ll a,ll b){return (a+b)%F;}
ll sub(ll a,ll b){return (a-b+llabs(a-b)/F*F+F)%F;}
void upd(ll &a,ll b){a=(a%F+b%F)%F;}
int a[MAXN],b[MAXN];
double c[MAXN];	
int main()
{
//	freopen("B.in","r",stdin);
	
	int n,T;
	cin>>T;
	while (T--)
	{
		cin>>n;
		For(i,n) scanf("%d",&a[i]);
		int ans=min(2,n);
		For(i,n-1) b[i]=a[i]-a[i+1];
		int p=2;
		Fork(i,2,n-1) if (b[i]==b[i-1]) ans=max(ans,++p);else p=2; 
		
		For(i,n-1) c[i]=(double)a[i]/(double)a[i+1];
		p=2;
		Fork(i,2,n-1) if (fabs(c[i]-c[i-1])<1e-8) ans=max(ans,++p);
		else p=2; 
		
		
		
		cout<<ans<<endl;
		
	}
	
	return 0;
}





版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5328(Problem Killer-暴力)

标签:

原文地址:http://blog.csdn.net/nike0good/article/details/47813557

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!