码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5410 CRB and His Birthday(DP)

时间:2015-08-20 20:58:50      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:

CRB and His Birthday

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 83    Accepted Submission(s): 45


Problem Description
Today is CRB‘s birthday. His mom decided to buy many presents for her lovely son.
She went to the nearest shop with M Won(currency unit).
At the shop, there are N kinds of presents.
It costs Wi Won to buy one present of i-th kind. (So it costs k × Wi Won to buy k of them.)
But as the counter of the shop is her friend, the counter will give Ai × x + Bi candies if she buys x(x>0) presents of i-th kind.
She wants to receive maximum candies. Your task is to help her.
1 ≤ T ≤ 20
1 ≤ M ≤ 2000
1 ≤ N ≤ 1000
0 ≤ Ai, Bi ≤ 2000
1 ≤ Wi ≤ 2000
 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains two integers M and N.
Then N lines follow, i-th line contains three space separated integers WiAi and Bi.
 

Output
For each test case, output the maximum candies she can gain.
 

Sample Input
1 100 2 10 2 1 20 1 1
 

Sample Output
21
Hint
CRB‘s mom buys 10 presents of first kind, and receives 2 × 10 + 1 = 21 candies.
 

Author
KUT(DPRK)
 

Source





#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

const int N = 2010;

int dp[N];
int p[N],w[N],k[N];
int n,m;
int flag[N][N];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&p[i],&w[i],&k[i]);
        }
        int maxx = 0;
        memset(flag,0,sizeof(flag));
        memset(dp,0,sizeof(dp));
        for(int i=0; i<m; i++)
        {
            for(int j=n; j>=p[i]; j--)
            {
                dp[j] = max(dp[j],dp[j-p[i]]+w[i]+k[i]);
                maxx = max(dp[j],maxx);
            }
        }
        for(int i=0;i<m;i++){
            for(int j=p[i];j<=n;j++){
                dp[j] = max(dp[j],dp[j-p[i]]+w[i]);
                maxx = max(dp[j],maxx);
            }
        }
        printf("%d\n",maxx);
    }

    return 0;
}


 

版权声明:本文为博主原创文章,如有特殊需要请与博主联系 QQ : 793977586。

HDU 5410 CRB and His Birthday(DP)

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/47813431

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!