码迷,mamicode.com
首页 > 其他好文 > 详细

最小生成树第一弹

时间:2015-08-20 22:09:39      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:

题目描述 Description

农民约翰被选为他们镇的镇长!他其中一个竞选承诺就是在镇上建立起互联网,并连接到所有的农场。当然,他需要你的帮助。 约翰已经给他的农场安排了一条高速的网络线路,他想把这条线路共享给其他农场。为了使花费最少,他想铺设最短的光纤去连接所有的农场。 你将得到一份各农场之间连接费用的列表,你必须找出能连接所有农场并所用光纤最短的方案。 每两个农场间的距离不会超过100000

输入描述 Input Description

第一行: 农场的个数,N(3<=N<=100)。

第二行..结尾: 接下来的行包含了一个N*N的矩阵,表示每个农场之间的距离。理论上,他们是N行,每行由N个用空格分隔的数组成,实际上,他们每行限制在80个字符以内,因此,某些行会紧接着另一些行。当然,对角线将会是0,因为线路从第i个农场到它本身的距离在本题中没有意义。

输出描述 Output Description

只有一个输出,是连接到每个农场的光纤的最小长度和。

样例输入 Sample Input

4

0  4  9 21

4  0  8 17

9  8  0 16

21 17 16  0

样例输出 Sample Output

28

这次用的是用结构体存储结构,然后写个自定义排序的函数就ok了

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct node{
int x;int y;int v;
};
node a[101];
int fa[101];
int f(int xx){
return xx==fa[xx]?xx:fa[xx]=f(fa[xx]);
}
int comp(const node&ee,const node&rr){
if(ee.v<rr.v) return 1;
return 0;
}
int main()
{
int m,n,i,j,k,s=0,ans=0;
scanf("%d",&n);
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
{
int ss;
scanf("%d",&ss);
if(ss!=0&&i<j)
{
m++;
a[m].x=i;
a[m].y=j;
a[m].v=ss;
}
}
for(i=1;i<=n;i++)
fa[i]=i;
sort(a+1,a+m+1,comp);
for(i=1;i<=m;i++){
if(f(a[i].x)!=f(a[i].y)){
fa[a[i].x]=a[i].y;
s++;
ans+=a[i].v;
}
if(s==n-1) break;
}
printf("%d\n",ans);
return 0;
}

最小生成树第一弹

标签:

原文地址:http://www.cnblogs.com/20003238wzc--/p/4746228.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!