码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1840 哈希

时间:2015-08-20 22:35:28      阅读:281      评论:0      收藏:0      [点我收藏+]

标签:

Eqs
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 14093   Accepted: 6927

Description

Consider equations having the following form:
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

Source

Romania OI 2002

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

short hash[25000001];  //hash[sum]表示值等于sum的的解的个数(多对1映射)

int main()                         //用int会MLE<span id="transmark"></span>
{
    int a1,a2,a3,a4,a5;  //系数
    scanf("%d%d%d%d%d",&a1,&a2,&a3,&a4,&a5);
    {
        memset(hash,0,sizeof(hash));
        for(int x1=-50; x1<=50; x1++)
        {
            if(!x1)
                continue;
            for(int x2=-50; x2<=50; x2++)
            {
                if(!x2)
                    continue;
                int sum=(a1*x1*x1*x1+a2*x2*x2*x2);
                if(sum<0)
                    sum+=25000000;
                hash[sum]++;
            }
        }
        int num=0;
        for(int x3=-50; x3<=50; x3++)
        {
            if(!x3)
                continue;
            for(int x4=-50; x4<=50; x4++)
            {
                if(!x4)
                    continue;
                for(int x5=-50; x5<=50; x5++)
                {
                    if(!x5)
                        continue;
                    int sum=a3*x3*x3*x3+a4*x4*x4*x4+a5*x5*x5*x5;
                    if(sum>12500000||sum<-12500000)  //防止特殊情况发生
						continue;
                    if(sum<0)
                        sum+=25000000;
                    if(hash[sum])
                        num+=hash[sum];
                }
            }
        }
        cout<<num<<endl;
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 1840 哈希

标签:

原文地址:http://blog.csdn.net/became_a_wolf/article/details/47816555

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!