码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj2680 Choose the best route

时间:2015-08-20 22:37:55      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10761    Accepted Submission(s): 3484


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
1 -1
该题用到了最短路径万能源点,
#include<queue>
#include<stdio.h>  
#include<string.h>
#define INL 0x3f3f3f3f
using namespace std;  
int vid[10000],x[1080][1080],vist[10000];  
int N,M,D;  
void spfa()  
{  
    for(int i=0;i<=N;i++)  
    {  
        vist[i]=INL;vid[i]=0;  
    }  
    queue<int> q;  
    vid[0]=1;  
    q.push(0);  
    vist[0]=0;
    while(!q.empty())  
    {  
        int u=q.front();  
            q.pop();  
           vid[u]=0;  
        for(int i=0;i<=N;i++)  
        {  
            if(vist[i]>vist[u]+x[u][i])  
            {  
                vist[i]=vist[u]+x[u][i];  
                if(!vid[i])  
                {  
                    q.push(i);  
                    vid[i]=1;  
                }  
            }  
        }  
    }  
}  
int main()  
{  
    while(scanf("%d%d%d",&N,&M,&D)!=EOF)  
    {  
	    memset(x,INL,sizeof(x));
        int a,b,c;
        for(int i=0;i<M;i++)
        {
        	 scanf("%d%d%d",&a,&b,&c);
        	 if(x[a][b]>c)
        	 x[a][b]=c;
        }
        int n,g,min;
        scanf("%d",&n);
	        for(int i=0;i<n;i++)
	        {
	        	scanf("%d",&g);
	        	x[0][g]=0;//万能源点知识
	        }
        spfa();
        if(vist[D]==INL)
             printf("-1\n");
          else
            printf("%d\n",vist[D]); 
    }  
    return 0;  
}  





版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj2680 Choose the best route

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/47816191

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!