码迷,mamicode.com
首页 > 其他好文 > 详细

Codeforces Round #313 (Div. 2) C. Geralds Hexagon(补大三角.cpp

时间:2015-08-20 22:36:31      阅读:355      评论:0      收藏:0      [点我收藏+]

标签:



Description

Gerald got a very curious hexagon for his birthday. The boy found out that all the angles of the hexagon are equal to 技术分享. Then he measured the length of its sides, and found that each of them is equal to an integer number of centimeters. There the properties of the hexagon ended and Gerald decided to draw on it.

He painted a few lines, parallel to the sides of the hexagon. The lines split the hexagon into regular triangles with sides of 1 centimeter. Now Gerald wonders how many triangles he has got. But there were so many of them that Gerald lost the track of his counting. Help the boy count the triangles.

Input

The first and the single line of the input contains 6 space-separated integers a1,?a2,?a3,?a4,?a5 and a6 (1?≤?ai?≤?1000) — the lengths of the sides of the hexagons in centimeters in the clockwise order. It is guaranteed that the hexagon with the indicated properties and the exactly such sides exists.

Output

Print a single integer — the number of triangles with the sides of one 1 centimeter, into which the hexagon is split.

Sample Input

Input
1 1 1 1 1 1
Output
6
Input
1 2 1 2 1 2
Output
13

Sample Output

Hint

This is what Gerald‘s hexagon looks like in the first sample:

技术分享

And that‘s what it looks like in the second sample:

技术分享



题意:

已知六边形的六条边长,求由多少个单位三等边角形拼成。边长按顺时针顺序给出,以单位三角形边长为单位。

思路:

六边形补成大等边三角形。因为边长为n的大三角形由n*n个小单位角形拼成,更容易计算。大三角形减去三个角变成六边形,减去的三个小三角形的这边长正好等于六边形中对应的的三条边长。因此,设大三角边长为s,三个小三角形边长分别为a,b,c,那个单位三角形个数为  s*s-(a*a+b*b+c*c).而 s 正好等于六边形相邻三条边之和,a,b,c 则分别等于六边形相隔的三条边,因此很容易得出答案,可以画图加深了解。

代码:

#include<cstdio>
using namespace std;
int a[7];
int main()
{
    int s;
    int ans;
    for(int i=0;i<6;i++)
        scanf("%d",&a[i]);
        s=a[0]+a[1]+a[2];
        ans=s*s-(a[0]*a[0]+a[2]*a[2]+a[4]*a[4]);
        printf("%d\n",ans);

    return 0;
}

 

版权声明:本文为博主原创文章,未经博主允许不得转载。

Codeforces Round #313 (Div. 2) C. Geralds Hexagon(补大三角.cpp

标签:

原文地址:http://blog.csdn.net/a1967919189/article/details/47816395

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!