码迷,mamicode.com
首页 > 其他好文 > 详细

poj2109 Power of Cryptography(数学题)

时间:2014-07-12 20:48:01      阅读:279      评论:0      收藏:0      [点我收藏+]

标签:数学   poj   

题目链接:http://poj.org/problem?id=2109

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
This problem involves the efficient computation of integer roots of numbers. 
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn = p.

Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input

2 16
3 27
7 4357186184021382204544

Sample Output

4
3
1234

代码如下:

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
	double n, p, k;
	while(cin >> n >> p)
	{
		k = pow(p,1/n);
		cout<<k<<endl;
	}
	return 0;
}


poj2109 Power of Cryptography(数学题),布布扣,bubuko.com

poj2109 Power of Cryptography(数学题)

标签:数学   poj   

原文地址:http://blog.csdn.net/u012860063/article/details/37657471

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!