码迷,mamicode.com
首页 > 其他好文 > 详细

Beat the Spread!

时间:2015-08-21 09:31:03      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5474    Accepted Submission(s): 2857


Problem Description
Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?
 

Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.
 

Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.
 

Sample Input
2 40 20 20 40
 

Sample Output
30 10 impossible
#include<stdio.h>
int main()
{
	int n;
	scanf("%d",&n);
		while(n--)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			if((a+b)%2==0&&(a-b)%2==0&&(a+b)/2>=0&&(a-b)/2>=0)
			printf("%d %d\n",(a+b)/2,(a-b)/2);
			else
			printf("impossible\n");
		}
		return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Beat the Spread!

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/47829447

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!