码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 1513 Palindrome

时间:2015-08-21 13:43:45      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:palindrome   hdoj 1513   lcs   dp   

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4194    Accepted Submission(s): 1427


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
5 Ab3bd
 

Sample Output
2
 倒转字符串,然后与原字符串求最长公共子序列,然后用长度减就行了;
但这个题目要求字符串为5000,所以二维数组肯定爆内存,所以用滚动数组,用dp[2][5500]即可!
#include<stdio.h>
#include<string.h>
#define N 5500
int dp[2][N];
char s1[N],s2[N];
int max(int a,int b)
{
	return a>b?a:b;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		int len,i,j; 
		getchar();
		scanf("%s",s1);
		len=strlen(s1);
		for(i=len-1,j=0;i>=0;i--)//字符串倒序 
		{
			s2[i]=s1[j++];
		}
		for(i=1;i<=len;i++)
		  for(j=1;j<=len;j++)
		   {
		   	 int x=i%2;//在两行之间 循环进行 
		   	 int y=1-x;
		   	 if(s1[i-1]==s2[j-1])
		   	 dp[x][j]=dp[y][j-1]+1;
		   	 else
		   	 dp[x][j]=max(dp[x][j-1],dp[y][j]);
		   }
		   printf("%d\n",len-dp[len%2][len]);
	}
	return 0;
} 



版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj 1513 Palindrome

标签:palindrome   hdoj 1513   lcs   dp   

原文地址:http://blog.csdn.net/zhangxiaoxiang123/article/details/47831895

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!