码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 1221 Risk【最短路 floyd】

时间:2015-08-21 13:50:06      阅读:235      评论:0      收藏:0      [点我收藏+]

标签:


ZOJ Problem Set - 1221
Risk

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Risk is a board game in which several opposing players attempt to conquer the world. The gameboard consists of a world map broken up into hypothetical countries. During a player‘s turn, armies stationed in one country are only allowed to attack only countries with which they share a common border. Upon conquest of that country, the armies may move into the newly conquered country.

During the course of play, a player often engages in a sequence of conquests with the goal of transferring a large mass of armies from some starting country to a destination country. Typically, one chooses the intervening countries so as to minimize the total number of countries that need to be conquered. Given a description of the gameboard with 20 countries each with between 1 and 19 connections to other countries, your task is to write a function that takes a starting country and a destination country and computes the minimum number of countries that must be conquered to reach the destination. You do not need to output the sequence of countries, just the number of countries to be conquered including the destination. For example, if starting and destination countries are neighbors, then your program should return one.

The following connection diagram illustrates the sample input.

技术分享


Input

Input to your program will consist of a series of country configuration test sets. Each test set will consist of a board description on lines 1 through 19. The representation avoids listing every national boundary twice by only listing the fact that country I borders country J when I < J. Thus, the Ith line, where I is less than 20, contains an integer X indicating how many "higher-numbered" countries share borders with country I, then X distinct integers J greater than I and not exceeding 20, each describing a boundary between countries I and J. Line 20 of the test set contains a single integer (1 <= N <= 100) indicating the number of country pairs that follow. The next N lines each contain exactly two integers (1 <= A,B <= 20; A!=B) indicating the starting and ending countries for a possible conquest.

There can be multiple test sets in the input; your program should continue reading and processing until reaching the end of file. There will be at least one path between any two given countries in every country configuration.


Output

For each input set, your program should print the following message "Test Set #T" where T is the number of the test set starting with 1. The next NT lines each will contain the result for the corresponding test in the test set - that is, the minimum number of countries to conquer. The test result line should contain the start country code A the string " to " the destination country code B ; the string ": " and a single integer indicating the minimum number of moves required to traverse from country A to country B in the test set. Following all result lines of each input set, your program should print a single blank line.


Sample Input

1 3 
2 3 4 
3 4 5 6 
1 6 
1 7 
2 12 13 
1 8 
2 9 10 
1 11 
1 11 
2 12 17 
1 14 
2 14 15 
2 15 16 
1 16 
1 19 
2 18 19 
1 20 
1 20 

1 20 
2 9 
19 5 
18 19 
16 20


Sample Output

Test Set #1 
1 to 20: 7 
2 to 9: 5 
19 to 5: 6 
18 to 19: 2 
16 to 20: 2 


Source: South Central USA 1997


一下子看到这道题有点蒙,第一英文题读不懂(我英文不好),第二测试数据太长了。。。20+n 行,看了大牛博客后 懂了一些,我采用的是 floyd 方法,对于测试数据怎么输入及怎么处理(放进图)是个问题。

具体的看代码吧。1A:

技术分享



#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define min(a,b) a>b?b:a
#define INF 0x3f3f3f3f
int dis[22][22];
void floyd()
{
	int i,j,k;
	for(k = 1; k <= 20; k++)
	for(i = 1; i <= 20; i++)
	for( j = 1; j <=20; j++)
	dis[i][j] = min(dis[i][j], dis[i][k]+dis[k][j]);
}
int main()
{
	int i,j,k,from,to,next,n,a,b,c,cs=1;//cs 格式控制 :Test Set #1
	while(scanf("%d",&n)!=EOF)//第一行 
	{
		memset(dis,0x3f,sizeof(dis));// 数组 先赋值为无穷大 
		while(n--)
		{
			scanf("%d",&to);
			dis[1][to] = dis[to][1] = 1; //第一行点to到 1的距离 定为1 
		}
		for(i = 2; i <= 19; i++) //第2到19行 
		{
			scanf("%d",&a);
			while(a--)//a个点到i的距离 也定为 1 
			{
				scanf("%d",&to);
				dis[i][to] = dis[to][i] = 1;
			}
		}
		floyd();
		scanf("%d",&b);//b组 起点、终点 
		printf("Test Set #%d\n",cs++);
		while(b--)
		{
			scanf("%d%d",&from, &to);//输入 起点、终点 
			printf("%d to %d: %d\n",from,to,dis[from][to]);//格式输出 
		}
		printf("\n");//千万别忘了!!!题目输出要求每组测试数据后跟空行 
	}
	return 0;
}






版权声明:原创文章,若要转载,请与博主联系,谢谢

zoj 1221 Risk【最短路 floyd】

标签:

原文地址:http://blog.csdn.net/liu6886/article/details/47831327

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!