码迷,mamicode.com
首页 > 其他好文 > 详细

数论-线性方程——Program H

时间:2015-08-21 21:04:21      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:

线性方程

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The Sky is Sprite. 
The Birds is Fly in the Sky. 
The Wind is Wonderful. 
Blew Throw the Trees 
Trees are Shaking, Leaves are Falling. 
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei 



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem! 
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. 
 
技术分享
 

Input

The input contains multiple test cases. 
Each case two nonnegative integer a,b (0<a, b<=2^31) 
 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 
 

Sample Input

  77   51
 
 
  10   44
 
  34   79
 

Sample Output

  2   -3
 
  sorry
 
  7   -3
 
 
题目大意:已知线性方程ax+by=1;输入a,b的值,要求输出x,y的值,若没有,输出“sorry”。
 
 
分析:求线性方程的解用扩展欧几里得算法,再判断gcd(a,b)=d是否等于1.
 
 
 
 
 
 
 
代码如下:
#include <iostream>
#include <cstdio>


using namespace std;
void gcd(long long a,long long b,long long &d,long long &x,long long &y)
{
	if(!b)
	{
		d=a;
		x=1;
		y=0;
	}
	else
	{
		gcd(b,a%b,d,y,x);
		y-=x*(a/b);
	}
}
int main()
{
	long long  a,b;
	while(scanf("%lld%lld",&a,&b)==2)
	{
		long long d,x,y;
		gcd(a,b,d,x,y);
		if(d==1)
		{
			while(x<0)
			{
				x=x+b;
				y=y-a;
			}
			printf("%lld %lld\n",x,y);
		}
		else
			printf("sorry\n");
	}
	return 0;
}

数论-线性方程——Program H

标签:

原文地址:http://www.cnblogs.com/xl1164191281/p/4748741.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!