码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 2899 Strange fuction

时间:2015-08-21 21:31:23      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:strange fuction   hdoj 2899   二分   

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4795    Accepted Submission(s): 3420


Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
2 100 200
 

Sample Output
-74.4291 -178.8534
简单二分+数学:求导后二分找与y最接近的值,此时原函数最小;
#include<stdio.h>
#include<math.h>
double y;
double hanshu(double x)//原函数值 
{
	return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
double daoshu(double x)//导数值 
{
	return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x-y;
}
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%lf",&y);
		if(y>=daoshu(100))
		printf("%lf\n",hanshu(100));
		double right =100,left=0;
		while((right-left)>=1e-10)//二分 
		{
			double mid=(right+left)/2;
			if(daoshu(mid)>0)
			right=mid;
			else
			left=mid;
		}
		printf("%.4lf\n",hanshu(right));
	}
	return 0;
}




 

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj 2899 Strange fuction

标签:strange fuction   hdoj 2899   二分   

原文地址:http://blog.csdn.net/zhangxiaoxiang123/article/details/47841209

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!