码迷,mamicode.com
首页 > 其他好文 > 详细

light oj 1317

时间:2015-08-21 21:32:19      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:

Description

You probably have played the game "Throwing Balls into the Basket". It is a simple game. You have to throw a ball into a basket from a certain distance. One day we (the AIUB ACMMER) were playing the game. But it was slightly different from the main game. In our game we were N people trying to throw balls into M identical Baskets. At each turn we all were selecting a basket and trying to throw a ball into it. After the game we saw exactly S balls were successful. Now you will be given the value of N and M. For each player probability of throwing a ball into any basket successfully is P. Assume that there are infinitely many balls and the probability of choosing a basket by any player is 1/M. If multiple people choose a common basket and throw their ball, you can assume that their balls will not conflict, and the probability remains same for getting inside a basket. You have to find the expected number of balls entered into the baskets after K turns.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing three integers N (1 ≤ N ≤ 16), M (1 ≤ M ≤ 100) and K (0 ≤ K ≤ 100) and a real number P (0 P ≤ 1). P contains at most three places after the decimal point.

Output

For each case, print the case number and the expected number of balls. Errors less than 10-6 will be ignored.

Sample Input

2

1 1 1 0.5

1 1 2 0.5

Sample Output

Case 1: 0.5

Case 2: 1.000000


题意:
n个人 m个篮子 每一轮每个人可以选m个篮子中一个扔球 扔中的概率都是p 求k轮后所有篮子里面球数量的期望值
思路:
根据期望 的定义与篮筐个数无关,因为题目假设互不影响,结果就是N*K*P。
代码:
#include<cstdio>
using namespace std;
int main()
{
    int T;
    int casex=1;
    double N,M,K,P;
    double ans;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf%lf%lf%lf",&N,&M,&K,&P);
        ans=N*K*P;
        printf("Case %d: %lf\n",casex++,ans);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

light oj 1317

标签:

原文地址:http://blog.csdn.net/a1967919189/article/details/47840343

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!