码迷,mamicode.com
首页 > 其他好文 > 详细

Strange fuction HDU 2899 【二分】

时间:2015-08-21 21:33:05      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
2 100 200
 

Sample Output
-74.4291 -178.8534
 


#include <stdio.h>
#include <math.h>
int y;
double fun1(double x)
{
    return 42*pow(x,6) + 48*pow(x,5) + 21*x*x + 10*x - y;
}

double fun2(double x)
{
    return 6*pow(x,7) + 8*pow(x,6) + 7*x*x*x + 5*x*x-y*x;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&y);
        double left=0,right=100,middle;
        while(right-left>=1e-10)
        {
            middle=(left+right)/2;
            if(fun1(middle)>0) right=middle;
            else left=middle;
        }
        printf("%.4lf\n",fun2(left));
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Strange fuction HDU 2899 【二分】

标签:

原文地址:http://blog.csdn.net/yuzhiwei1995/article/details/47840181

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!