码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3041

时间:2015-08-21 21:34:24      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:acm   poj   二分图匹配   


Asteroids
Time Limit: 1000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

            

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source



题意: 在一张地图上,有一些小行星,你有一个武器,每使用一次就能摧毁一行或一列的行星,求摧毁所有行星需要使用的次数~ ~
思路: 想不到是二分图匹配啊 = = 所有的x作为一个集合,所有的y作为一个集合,x和y之间连边。转化为最小点覆盖问题, 最少覆盖的点数 = 最大匹配数,orz。

AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int n, k;
int g[505][505], linker[505], vis[505];
int Find(int x)
{
  for(int i = 1;i <= n;i ++)
  {
    if(!vis[i] && g[x][i])
	{
	  vis[i] = 1;
	  if(linker[i] == 0 || Find(linker[i]))
	  {
	    linker[i] = x;
	    return 1;
	  }
	}
  }
  return 0;
}
int main()
{
	int a, b, ans;
	while(scanf("%d%d", &n, &k) != EOF)
	{
	  ans = 0;
	  memset(g, 0, sizeof(g));
	  memset(linker, 0, sizeof(linker));
	  while(k --)
	  {
	   scanf("%d%d",&a, &b);
	   g[a][b] = 1;
	  }
	  for(int i = 1;i <= n;i ++)
	  {
	   memset(vis, 0, sizeof(vis));
	   if(Find(i)) ans ++;
	  }
	  printf("%d\n",ans);
    }
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 3041

标签:acm   poj   二分图匹配   

原文地址:http://blog.csdn.net/mowenwen_/article/details/47839929

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!