码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj1385 Minimum Transport Cost

时间:2015-08-21 21:33:41      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8805    Accepted Submission(s): 2320


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17

本题的大意是个运送货物需要交两部分费用,过路费和过城市费,如输出样例输入5,然后输入一个5*5的矩阵代表过路费,再输入5个数,代表过城市费,要求花的费用最低,并输出行走路线。


#include<stdio.h>
#define INL 0x3f3f3f3f
#define min(a,b) (a)>(b)?(b):(a)
int x[100][101],n,f[100],path[100][100];
void floyd()
{
	int i,j,k;
	for(i=1;i<=n;i++)
		   for(j=1;j<=n;j++)
		    path[i][j]=j;
	for(k=1;k<=n;k++)
	   for(i=1;i<=n;i++)
	     for(j=1;j<=n;j++)
	        {
	        	int h=x[i][k]+x[k][j]+f[k];
	        	if(x[i][j]>h)
	        	{
	        		x[i][j]=h;
	        		path[i][j]=path[i][k];
	        	}
	        	else if(x[i][j]==h)
	        	path[i][j]=min(path[i][j],path[i][k]);
	        }
}
int main()
{
	while(scanf("%d",&n),n)
	{
		int i,j,k,a,b,c;
		for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
		{
			scanf("%d",&x[i][j]);
			     if(x[i][j]==-1)
			          x[i][j]=INL;
		}
			for(j=1;j<=n;j++)
			   scanf("%d",&f[j]); 
			       floyd();
		while(scanf("%d%d",&b,&c),b!=-1)
		{
		      int w=b;
			printf("From %d to %d :\nPath: ",b,c);
				 while(w!=c)
				 {
				 	 printf("%d-->",w);
				 	 w=path[w][c];
				 } 
		    printf("%d\n",w);
			printf("Total cost : %d\n\n",x[b][c]);
	        }
	}
	return 0;
} 

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj1385 Minimum Transport Cost

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/47839561

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!