码迷,mamicode.com
首页 > 其他好文 > 详细

Random Teams(Codeforces Round 273)

时间:2015-08-21 21:33:41      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:

Description

n participants of the competition were split into m teams in some manner so that each team has at least one participant. After the competition each pair of participants from the same team became friends.

Your task is to write a program that will find the minimum and the maximum number of pairs of friends that could have formed by the end of the competition.

Input

The only line of input contains two integers n and m, separated by a single space (1?≤?m?≤?n?≤?109) — the number of participants and the number of teams respectively.

Output

The only line of the output should contain two integers kmin and kmax — the minimum possible number of pairs of friends and the maximum possible number of pairs of friends respectively.

Sample Input

Input
5 1
Output
10 10
Input
3 2
Output
1 1
Input
6 3
Output
3 6

Sample Output

Case 1: 0.5

Case 2: 1.000000

Hint

In the first sample all the participants get into one team, so there will be exactly ten pairs of friends.

In the second sample at any possible arrangement one team will always have two participants and the other team will always have one participant. Thus, the number of pairs of friends will always be equal to one.

In the third sample minimum number of newly formed friendships can be achieved if participants were split on teams consisting of 2 people, maximum number can be achieved if participants were split on teams of 1, 1 and 4 people.

题意:

给你n个人,把他们分配到m支队伍中去,每支队伍至少要有一个人,在一个队伍中的任意两个人都可以成为一对朋友,要你分配队伍,求出最少能够形成的朋友对数kmin,和最多能形成的队伍对数kmax.

思路:

当m=1的时候,也就是只有一支队伍,那么kmin=kmax=C(n,2);其余的情况求最大值的 时候我我们先把每个队伍分配一个人,然后把剩余的人全部分配到一个队伍,这样求得的为最大值,kmax=C(n-m+1,2),求最小值的时候,我们先把每个队伍都平均分配人数,剩余的人在任意选几个放一个人,kmin=(m-n%m)*C(n/m,2)+n%mC(n/m+n%m,2);

代码:

#include<cstdio>
using namespace std;
int main()
{
    long long   m,n;
  long long  kmin,kmax;
    while(scanf("%I64d%I64d",&n,&m)!=EOF)
    {
       if(m==1)
        {
            kmin=kmax=n*(n-1)/2;
        }
        else
        {
            kmax=(n-m+1)*(n-m)/2;
            if(n%m==0)
            {
                kmin=m*(n/m)*(n/m-1)/2;
            }
            else
            {
                kmin=(m-n%m)*(n/m)*(n/m-1)/2+(n%m)*(n/m+1)*(n/m)/2;
            }
        }

         printf("%I64d %I64d\n",kmin,kmax);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Random Teams(Codeforces Round 273)

标签:

原文地址:http://blog.csdn.net/a1967919189/article/details/47838999

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!