码迷,mamicode.com
首页 > 其他好文 > 详细

【POJ 3661】Running

时间:2015-08-21 23:17:14      阅读:169      评论:0      收藏:0      [点我收藏+]

标签:

Running
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5598   Accepted: 2102

Description

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her ‘exhaustion factor‘, which starts at 0. When she chooses to run in minute i, she will run exactly a distance ofDi (1 ≤ Di ≤ 1,000) and her exhaustion factor will increase by 1 -- but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches 0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie‘s exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run while satisfying the conditions.
 

Sample Input

5 2
5
3
4
2
10

Sample Output

9

Source

 
题意:从前有一只奶牛叫Bessie,它晨练减肥,以吸引男奶牛(以上纯属脑补)。它要从跑步中得到锻炼。它要跑N分钟,如果跑一分钟步它的疲劳度就会增加1,然而如果要休息,则疲劳度减1,如果它一开始休息就必须休息到疲劳度为0才能重新开始跑。
这是一道很简单的DP题。
设f[n][0]为答案,它可能从f[n - j][j]、f[i - 1][0]这两种状态转移过来,表示它可以从疲劳度为 j 时的第n - j 分钟就开始休息一直休息到第n分钟,后者则是它上一分钟就已经疲劳度为零了,所以不变。
那其余的f[i][j]就可以通过普通的01背包转移。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int MAXN = 10005;
const int MAXM = 505;
int d[MAXN];
int f[MAXN][MAXM];
int n;
int m;

int main()
{
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= n; ++i) scanf("%d", &d[i]);
    memset(f, 0, sizeof(f));
    for (int i = 1; i <= n; ++i)
    {
        f[i][0] = f[i - 1][0];
        for (int j = 1; j <= m && j <= i; ++j)
        {
            f[i][j] = max(f[i][j], f[i - 1][j - 1] + d[i]);
            f[i][0] = max(f[i][0], f[i - j][j]);
        }
    }
    printf("%d\n", f[n][0]);
    return 0;
}

 

【POJ 3661】Running

标签:

原文地址:http://www.cnblogs.com/albert7xie/p/4749158.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!