码迷,mamicode.com
首页 > 其他好文 > 详细

Slim Span

时间:2015-08-21 23:23:18      阅读:255      评论:0      收藏:0      [点我收藏+]

标签:

Description

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (V, E), where V is a set of vertices {v1, v2, …, vn} and E is a set of undirected edges {e1, e2, …, em}. Each edge eE has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n ? 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n ? 1 edges of T.

技术分享
Figure 5: A graph G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).

技术分享
Figure 6: Examples of the spanning trees of G

There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb, Tc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

n m  
a1 b1 w1
  ?  
am bm wm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ mn(n ? 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ek. wk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, ?1 should be printed. An output should not contain extra characters.

Sample Input

4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0

Sample Output

1
20
0
-1
-1
1
0
1686
50


题解:求生成树中最大边与最小边的差值的绝对值最小的一个。要知道差值就需要知道生成树的最大边和最小边,我们知道当我们用克鲁斯卡尔求最小生成树的时候,每次都是找最小边,构成的最小生成树的所有边都是最小的。如果我们遍历所有边,再在该边的基础上用克鲁斯求最小生成树,那么求得的最大边与该边的差值肯定最小。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int INF = 0x3fffffff;

struct Node
{
	int from;
	int to;
	int cost;
	bool operator< (Node t) const
	{
		return cost < t.cost;
	}
};

Node e[10004];
int pre[102];
int ans;

int find(int x)
{
	return x == pre[x] ? x : pre[x] = find(pre[x]);
}

void kruskal(int n,int k)
{
	sort(e,e + k);
	int cnt = 0;
	ans = INF;
	for(int i = 0;i < k;i++)
	{
		cnt = 0;
		for(int j = 1;j <= n;j++)
		{
			pre[j] = j;
		} 
		for(int j = i;j < k;j++)
		{
			int x = find(e[j].from);
			int y = find(e[j].to);
			if(x == y)
			{
				continue;
			}
			pre[x] = y;
			if(++cnt == n - 1)
			{
				ans = min(ans,e[j].cost - e[i].cost);
				break;
			}
		}
	}
	if(ans == INF)
	{
		ans = -1;
	}
}

int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m) != EOF && (n + m) != 0)
	{
		int u,v,c;
		for(int i = 0;i < m;i++)
		{
			scanf("%d%d%d",&u,&v,&c);
			e[i].from = u;
			e[i].to = v;
			e[i].cost = c;
		}
		
		kruskal(n,m);
		printf("%d\n",ans);
	}
	
	
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Slim Span

标签:

原文地址:http://blog.csdn.net/wang2534499/article/details/47843161

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!