码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1159 Palindrome(DP LCS)

时间:2015-08-25 12:02:34      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:dp

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2


题目大意:求插入最少的字符使得串为palindeome(回文串)。

遇到问题要剖析其原型,此题就是正序和逆序的LCS,结果来n-commenlength.


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#define LL long long
#define inf 0x3f3f3f3f
using namespace std;
short dp[5001][5001];
char a[5005],b[5005];
int main()
{
    int n,m,x,k,i,j;
    int cla;
    while(~scanf("%d",&n))
    {
        int s=0;
        dp[0][0]=0;<span id="transmark"></span>
        scanf("%s",a);
        for(i=n-1;i>=0;i--)
        b[s++]=a[i];
        b[s]='\0';
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(a[i-1]==b[j-1])
                {
                    dp[i][j]=dp[i-1][j-1]+1;
                }
                else
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            }
        }
        cout<<n-dp[n][n]<<endl;
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 1159 Palindrome(DP LCS)

标签:dp

原文地址:http://blog.csdn.net/grit_icpc/article/details/47974055

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!