标签:
Description
The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.
As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.
A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.
Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.
Input
Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
- A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
- m lines each containing a single base sequence consisting of 60 bases.
Output
For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities"
instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.
Sample Input
3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT
Sample Output
no significant commonalities
AGATAC
CATCATCAT
题解:求最长的公共字串并且按照字典序找最小的一个,由于长度小,暴力。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;
string s[20];
int main()
{
int ncase;
cin>>ncase;
while(ncase--)
{
int n;
scanf("%d",&n);
for(int i = 0;i < n;i++)
{
cin>>s[i];
}
bool flag = false;
string res = "Z";
for(int i = 60;i > 2;i--)
{
for(int j = 0;j <= 60 - i;j++)
{
string s1(s[0],j,i);
bool f = true;
for(int k = 1;k < n;k++)
{
if(s[k].find(s1) == string::npos)
{
f = false;
break;
}
}
if(f)
{
if(res > s1)
{
res = s1;
}
flag = true;
}
}
if(flag)
{
break;
}
}
if(flag)
{
cout<<res<<endl;
}
else
{
cout<<"no significant commonalities\n";
}
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
Blue Jeans
标签:
原文地址:http://blog.csdn.net/wang2534499/article/details/47973931