码迷,mamicode.com
首页 > 其他好文 > 详细

poj1979 DFS

时间:2015-08-25 16:42:51      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:dfspan idtransmarksp

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
Source

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<map>
#include<algorithm>
#include<set>
#define INF 0x3f3f3f3f

using namespace std;

int n,m;
char a[300][300];
int vis[300][300];
int lx,ly;
int dx[]= {-1,1,0,0};
int dy[]= {0,0,-1,1};
int num=0;
int dp[300][300];
int panduan(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<m)
        return 1;
    return 0;
}
int DFS(int x,int y)
{
    if(!panduan(x,y)||a[x][y]=='#')
        return 0;
    if(vis[x][y]==0)
    {
        vis[x][y]=1;
        for(int i=0; i<4; i++)
        {
            int fx=dx[i]+x;
            int fy=dy[i]+y;
            if(panduan(fx,fy)&&vis[fx][fy]==0&&a[fx][fy]=='.')
            {
                DFS(fx,fy);
                num++;
            }
        }
        //vis[x][y]=0;  //走过的点就不用再走了
    }
    return 1;
}
int main()
{
    while(~scanf("%d%d",&m,&n))
    {
        if(!m&&!n)
            break;
        int flag=1;
        memset(vis,0,sizeof(vis));
        for(int i=0; i<n; i++)
        {
            scanf("%s",a[i]);
            if(flag)
            {
                for(int j=0; j<m; j++)
                {
                    if(a[i][j]=='@')
                    {
                        flag=0;<span id="transmark"></span>  lx=i;ly=j;
                        break;
                    }
                }
            }
        }
        num=0;
        DFS(lx,ly);
        printf("%d\n",num+1);
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

poj1979 DFS

标签:dfspan idtransmarksp

原文地址:http://blog.csdn.net/became_a_wolf/article/details/47977617

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!