码迷,mamicode.com
首页 > 其他好文 > 详细

【POJ 3615】Cow Hurdles

时间:2015-08-25 18:54:32      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:

Cow Hurdles
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6486   Accepted: 2948

Description

Farmer John wants the cows to prepare for the county jumping competition, so Bessie and the gang are practicing jumping over hurdles. They are getting tired, though, so they want to be able to use as little energy as possible to jump over the hurdles.

Obviously, it is not very difficult for a cow to jump over several very short hurdles, but one tall hurdle can be very stressful. Thus, the cows are only concerned about the height of the tallest hurdle they have to jump over.

The cows‘ practice room has N (1 ≤ N ≤ 300) stations, conveniently labeled 1..N. A set of M (1 ≤ M ≤ 25,000) one-way paths connects pairs of stations; the paths are also conveniently labeled 1..M. Path i travels from station Si to station Ei and contains exactly one hurdle of height Hi (1 ≤ Hi ≤ 1,000,000). Cows must jump hurdles in any path they traverse.

The cows have T (1 ≤ T ≤ 40,000) tasks to complete. Task i comprises two distinct numbers, Ai and Bi (1 ≤ Ai ≤ N; 1 ≤ Bi ≤ N), which connote that a cow has to travel from station Ai to station Bi (by traversing over one or more paths over some route). The cows want to take a path the minimizes the height of the tallest hurdle they jump over when traveling from Ai to Bi . Your job is to write a program that determines the path whose tallest hurdle is smallest and report that height.
 

Input

* Line 1: Three space-separated integers: NM, and T
* Lines 2..M+1: Line i+1 contains three space-separated integers: Si , Ei , and Hi 
* Lines M+2..M+T+1: Line i+M+1 contains two space-separated integers that describe task i: Ai and Bi

Output

* Lines 1..T: Line i contains the result for task i and tells the smallest possible maximum height necessary to travel between the stations. Output -1 if it is impossible to travel between the two stations.

Sample Input

5 6 3
1 2 12
3 2 8
1 3 5
2 5 3
3 4 4
2 4 8
3 4
1 2
5 1

Sample Output

4
8
-1

Source

 
裸的传递闭包啊啊啊。
醉了。。。不说了。我想静静。
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int MAXN = 305;

int dis[MAXN][MAXN];
int n;
int m;
int t;

int main()
{
    memset(dis, 0x7f, sizeof(dis));
    scanf("%d%d%d", &n, &m, &t);
    for (int i = 0; i < m; ++i)
    {
        int u;
        int v;
        int w;
        scanf("%d%d%d", &u, &v, &w);
        dis[u][v] = min(dis[u][v], w);
    }
    for (int k = 1; k <= n; ++k)
        for (int i = 1; i <= n; ++i)
            if (k != i)
                for (int j = 1; j <= n; ++j)
                    if (k != j && i != j) dis[i][j] = min(dis[i][j], max(dis[i][k], dis[k][j]));
    while (t--)
    {
        int u;
        int v;
        scanf("%d%d", &u, &v);
        if (dis[u][v] > 1000000) printf("-1\n");
        else printf("%d\n", dis[u][v]);
    }
    return 0;
}

 

【POJ 3615】Cow Hurdles

标签:

原文地址:http://www.cnblogs.com/albert7xie/p/4757864.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!