码迷,mamicode.com
首页 > 其他好文 > 详细

C hicken and rabbit s

时间:2015-08-25 19:34:25      阅读:252      评论:0      收藏:0      [点我收藏+]

标签:

时间限制: 1 Sec  内存限制: 32 MB

提交: 40  解决: 29
[提交][状态][讨论版]

题目描述

Chicken and rabbits are in a same cage. As we all know, chicken has two legs but rabbit has four. Now
we know the number of legs in the cage is A, please tell me how many animals may in the cage at least
and at most.

输入

The first line of the input contains the number of test cases in the file. Each test case that follows
consists of one lines. each case contains only one integer numbers A specifying the total legs in the
cage .

输出

For each test case, print a line contains the answer

样例输入

2
3
20

样例输出

0 0
5 10


#include<stdio.h> 
int main() 
{ 
     int n; 
    scanf("%d",&n); 
    while(n--) 
    { 
        long long m; 
        scanf("%lld",&m); 
        if(m%2==1) 
        { 
            printf("0 0\n"); 
            continue;  
        }    
        if(m%4==0) 
        printf("%lld ",m/4); 
        else
        printf("%lld ",m/4+1); 
        printf("%lld\n",m/2); 
    } 
    return 0; 
    } 
/************************************************************** 
    Problem: 1205  
    Language: C 
    Result: 正确 
    Time:0 ms 
    Memory:768 kb 
****************************************************************/


版权声明:本文为博主原创文章,未经博主允许不得转载。

C hicken and rabbit s

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/47981545

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!