码迷,mamicode.com
首页 > 其他好文 > 详细

Buildings

时间:2015-08-25 19:36:44      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:acm

Buildings

Time Limit: 2000ms
Memory Limit: 32768KB
64-bit integer IO format: %I64d      Java class name: Main
  Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.
  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.
  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.
  Each floor has its own weight wi and strength si. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σwj)-si, where (Σwj) stands for sum of weight of all floors above.
  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.
  Now, it’s up to you to calculate this value.

Input

  There’re several test cases.
  In each test case, in the first line is a single integer N (1 <= N <= 105) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers wi and si (0 <= wi, si <= 100000) separated by single spaces.
  Please process until EOF (End Of File).

Output

  For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.
  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.

Sample Input

3
10 6
2 3
5 4
2
2 2
2 2
3
10 3
2 5
3 3

Sample Output

1
0
2
#include <cstdio>
#include <iostream>
#include <algorithm>

using namespace std;
#define N 100000 + 10
#define INF 0x3f3f3f3f
#define LL long long

struct E
{
    int w, s;
}e[N];

int n;

int cmp(E a, E b)
{
    return a.s + a.w < b.s + b.w ;
}

int main()
{
    while(~scanf("%d", &n))
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%d%d", &e[i].w, &e[i].s);
        }
        sort(e + 1, e + 1 + n, cmp);
        LL tmp = e[1].w;
        LL ans = -INF;
        for(int i = 2; i <= n; i++)
        {
            LL t = tmp - e[i].s;
            ans = max(ans, t);
            tmp += e[i].w;
        }
        if(ans < 0)
        printf("0\n");
        else printf("%I64d\n", ans);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Buildings

标签:acm

原文地址:http://blog.csdn.net/dojintian/article/details/47981205

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!