码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 2824 The Euler function

时间:2015-08-25 21:34:42      阅读:87      评论:0      收藏:0      [点我收藏+]

标签:

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4548    Accepted Submission(s): 1895


Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 

Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 

Output
Output the result of (a)+ (a+1)+....+ (b)
 

Sample Input
3 100
 

Sample Output
3042
 


代码:

 

#include<stdio.h>
#define MAX 3000010
long long euler[MAX];
int init()
{
	int i,j;
	for(i=2;i<MAX;i++)
	{
		if(!euler[i])
		{
			for(j=i;j<MAX;j+=i)
			{
				if(!euler[j])
				euler[j]=j;
				euler[j]=euler[j]/i*(i-1);
			}
		}
		euler[i]+=euler[i-1];
	}
}
int main()
{
	int a,b;
	init();
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		printf("%lld\n",euler[b]-euler[a-1]);
	}
	return 0;
}


 

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj 2824 The Euler function

标签:

原文地址:http://blog.csdn.net/longge33445/article/details/47984105

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!