码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 题目3966 Aragorn's Story(Link Cut Tree成段加减点权,查询点权)

时间:2015-08-25 21:36:04      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:

Aragorn‘s Story

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5505    Accepted Submission(s): 1441


Problem Description
Our protagonist is the handsome human prince Aragorn comes from The Lord of the Rings. One day Aragorn finds a lot of enemies who want to invade his kingdom. As Aragorn knows, the enemy has N camps out of his kingdom and M edges connect them. It is guaranteed that for any two camps, there is one and only one path connect them. At first Aragorn know the number of enemies in every camp. But the enemy is cunning , they will increase or decrease the number of soldiers in camps. Every time the enemy change the number of soldiers, they will set two camps C1 and C2. Then, for C1, C2 and all camps on the path from C1 to C2, they will increase or decrease K soldiers to these camps. Now Aragorn wants to know the number of soldiers in some particular camps real-time.
 

Input
Multiple test cases, process to the end of input.

For each case, The first line contains three integers N, M, P which means there will be N(1 ≤ N ≤ 50000) camps, M(M = N-1) edges and P(1 ≤ P ≤ 100000) operations. The number of camps starts from 1.

The next line contains N integers A1, A2, ...AN(0 ≤ Ai ≤ 1000), means at first in camp-i has Ai enemies.

The next M lines contains two integers u and v for each, denotes that there is an edge connects camp-u and camp-v.

The next P lines will start with a capital letter ‘I‘, ‘D‘ or ‘Q‘ for each line.

‘I‘, followed by three integers C1, C2 and K( 0≤K≤1000), which means for camp C1, C2 and all camps on the path from C1 to C2, increase K soldiers to these camps.

‘D‘, followed by three integers C1, C2 and K( 0≤K≤1000), which means for camp C1, C2 and all camps on the path from C1 to C2, decrease K soldiers to these camps.

‘Q‘, followed by one integer C, which is a query and means Aragorn wants to know the number of enemies in camp C at that time.
 

Output
For each query, you need to output the actually number of enemies in the specified camp.
 

Sample Input
3 2 5 1 2 3 2 1 2 3 I 1 3 5 Q 2 D 1 2 2 Q 1 Q 3
 

Sample Output
7 4 8
Hint
1.The number of enemies may be negative. 2.Huge input, be careful.
 

Source
 

Recommend
We have carefully selected several similar problems for you:  3965 3962 3963 3967 3968 

 瞬秒一A~~

题目大意:一个图,每个点都有点权,3种操作,I a b,a到b的点点权加一个值,D是减一个值,Q是查询这个点的点权

网上大都是树链剖分写的,提交了俩发现速度并不比我的快,,真的不知道前边300多毫秒的咋写的

技术分享

#include<stdio.h>           
#include<string.h>       
#include<queue>     
#include<iostream>     
#define INF 0x7fffffff     
#define max(a,b) (a>b?a:b)     
using namespace std;    
int vis[50050];        
struct LCT        
{        
    int bef[50050],pre[50050],next[50050][2],key[50050],add[50050];        
    void init()        
    {        
        memset(pre,0,sizeof(pre));        
        memset(next,0,sizeof(next));  
        memset(key,0,sizeof(key));
        memset(add,0,sizeof(add));
    }      
    void pushdown(int x)
    {
        if(add[x])
        {
            int a,b;
            a=next[x][0];
            b=next[x][1];
            if(a)//不用加,实际上,同下边那个b<span id="transmark"></span>
            {
                add[a]+=add[x];
                key[a]+=add[x];
            }
            if(b)
            {
                add[b]+=add[x];
                key[b]+=add[x];
            }
            add[x]=0;
        }
    }
    void rotate(int x,int kind)        
    {        
        int y,z;        
        y=pre[x];        
        z=pre[y];
        pushdown(y);
        pushdown(x);
        next[y][!kind]=next[x][kind];        
        pre[next[x][kind]]=y;        
        next[z][next[z][1]==y]=x;        
        pre[x]=z;        
        next[x][kind]=y;        
        pre[y]=x;        
    }        
    void splay(int x)        
    {        
        int rt;        
        for(rt=x;pre[rt];rt=pre[rt]);        
        if(x!=rt)        
        {        
            bef[x]=bef[rt];        
            bef[rt]=0;  
            pushdown(x);
            while(pre[x])        
            {        
                if(next[pre[x]][0]==x)        
                {        
                    rotate(x,1);        
                }        
                else      
                    rotate(x,0);        
            }         
        }        
    }        
    void access(int x)        
    {        
        int fa;        
        for(fa=0;x;x=bef[x])        
        {        
            splay(x); 
            pushdown(x);
            pre[next[x][1]]=0;        
            bef[next[x][1]]=x;        
            next[x][1]=fa;        
            pre[fa]=x;        
            bef[fa]=0;        
            fa=x;         
        }        
    }        
    void change(int x,int y,int val)    
    {    
       access(y);    
        for(y=0;x;x=bef[x])    
        {    
            splay(x);    
            if(!bef[x])    
            {    
                 key[x]+=val;
                 key[y]+=val;
                 key[next[x][1]]+=val;
                 add[next[x][1]]+=val;
                 add[y]+=val;
                 return;
            }   
            pushdown(x);
            pre[next[x][1]]=0;    
            bef[next[x][1]]=x;    
            next[x][1]=y;    
            pre[y]=x;    
            bef[y]=0;    
            y=x;       
        }       
    }    
    int query(int x)    
    {    
       splay(x);
       return key[x];
    }    
}lct;    
struct s    
{    
    int u,v,next;    
}edge[100020<<1];    
int head[100020],cnt;    
void add(int u,int v)    
{    
    edge[cnt].u=u;    
    edge[cnt].v=v;    
    edge[cnt].next=head[u];    
    head[u]=cnt++;    
}    
void bfs(int u)       
{                     
    queue<int>q;            
    memset(vis,0,sizeof(vis));            
    vis[u]=1;            
    q.push(u);            
    while(!q.empty())            
    {                
        u=q.front();                
        q.pop();                
        for(int i=head[u];i!=-1;i=edge[i].next)                
        {                    
            int v=edge[i].v;                    
            if(!vis[v])                    
            {                        
                lct.bef[v]=u;                                      
                vis[v]=1;                        
                q.push(v);                    
            }                
        }            
    }        
}  
int main()
{
    int n,m,q;
    while(scanf("%d%d%d",&n,&m,&q)!=EOF)
    {
        int i;
        lct.init();
        cnt=0;
        memset(head,-1,sizeof(head));
        for(i=1;i<=n;i++)
        {
            scanf("%d",&lct.key[i]);
        }
        for(i=0;i<m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            add(u,v);
            add(v,u);
        }
        bfs(1);
        while(q--)
        {
            char op[2];
            scanf("%s",op);
            if(op[0]=='I')
            {
                int x,y,val;
                scanf("%d%d%d",&x,&y,&val);
                lct.change(x,y,val);
            }
            else
                if(op[0]=='D')
                {
                    int x,y,val;
                    scanf("%d%d%d",&x,&y,&val);
                    lct.change(x,y,-val);
                }
                else
                    if(op[0]=='Q')
                    {
                        int x;
                        scanf("%d",&x);
                        printf("%d\n",lct.query(x));
                    }
        }
    }
}




版权声明:本文为博主原创文章,未经博主允许不得转载。

HDOJ 题目3966 Aragorn's Story(Link Cut Tree成段加减点权,查询点权)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/47983577

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!