码迷,mamicode.com
首页 > 其他好文 > 详细

How Many Answers Are Wrong

时间:2015-08-25 23:15:44      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:

Description

TT and FF are ... friends. Uh... very very good friends -________-b 

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored). 
技术分享

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF‘s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers. 

Boring~~Boring~~a very very boring game!!! TT doesn‘t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose. 

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence. 

However, TT is a nice and lovely girl. She doesn‘t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed. 

What‘s more, if FF finds an answer to be wrong, he will ignore it when judging next answers. 

But there will be so many questions that poor FF can‘t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy) 
 

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions. 

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It‘s guaranteed that 0 < Ai <= Bi <= N. 

You can assume that any sum of subsequence is fit in 32-bit integer. 
 

Output

A single line with a integer denotes how many answers are wrong.
 

Sample Input

10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
 
即给出10个数,五组测试数据
从1到10和为100
从7到10和为28
从1到3和为32
从4到6和为41
从6到6和为1
求给出的测试数据有几组是错的 

Sample Output

1
 
 
第三次遇到并查集了,这次一定要牢记,不要还是写不出来了,
另:每次给提供的数据其实是在一个集合内
 
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN=200010;
int F[MAXN];
int val[MAXN];
int find(int x)
{
    if(F[x]==-1)return x;
    int tmp=find(F[x]);
    val[x]+=val[F[x]];
    return F[x]=tmp;
}
int main()
{
    int n,m;
    int u,v,w;
    while(scanf("%d%d",&n,&m)==2)
    {
        memset(F,-1,sizeof(F));
        memset(val,0,sizeof(val));
        int ans=0;
        while(m--)
        {
            scanf("%d%d%d",&u,&v,&w);
            u=u-1;
            int t1=find(u);
            int t2=find(v);
            if(t1!=t2)
            {
                F[t2]=t1;
                val[t2]=val[u]-val[v]+w;
            }
            else
            {
                if(val[v]-val[u]!=w)ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

  

 
 

How Many Answers Are Wrong

标签:

原文地址:http://www.cnblogs.com/rain-1/p/4758715.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!