码迷,mamicode.com
首页 > 其他好文 > 详细

Piggy-Bank (完全背包)

时间:2015-08-25 23:18:36      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:

Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it‘s weight in grams. 
 

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
 

Sample Input

3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 

Sample Output

The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
 
 
就是说输入测试数据数
输入空的存钱罐的重量以及满了的重量
输入硬币种类数n
以下n行输入n种硬币每个硬币的重量以及面值
求此情况下该存钱罐至少能存的钱数,无解就输出无解
这个代码不是我写的,但是这道题比较有代表性,所以收藏起来学习
动态和背包我有点搞不清了
#include<stdio.h>
#include<string.h>
#define INF 0x7ffffff
#define MAXN 10000
int dp[MAXN+10];//dp[i]表容量为i的时候所装东西的最小价值
int main()
{
    int w1,w2;
    int P,W;
    int T,n;
    int i,j;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&w1,&w2);
        scanf("%d",&n);
        for(i=1;i<=w2-w1;i++)
           dp[i]=INF;//初始化为无穷大
        dp[0]=0;
        while(n--)
        {
            scanf("%d%d",&P,&W);
            for(i=W;i<=w2-w1;i++)
                if(dp[i]>dp[i-W]+P)
                   dp[i]=dp[i-W]+P;
        }
        if(dp[w2-w1]==INF) printf("This is impossible.\n");
        else
           printf("The minimum amount of money in the piggy-bank is %d.\n",dp[w2-w1]);     
    }    
    return 0;
}

  

Piggy-Bank (完全背包)

标签:

原文地址:http://www.cnblogs.com/rain-1/p/4758705.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!