码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 4324 Triangle LOVE

时间:2015-08-26 01:58:29      阅读:204      评论:0      收藏:0      [点我收藏+]

标签:triangle love   hdoj 4324   拓扑排序超时   拓扑排序   

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3903    Accepted Submission(s): 1537


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.
It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
Case #1: Yes Case #2: No
注意。注意,注意,取边,用字符串,不然超时!!!
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
#include<string.h>
#include<queue>
#define N  2010
struct line
{
    int u,v,next;
}edge[N*N];
int n,m,inde[N],head[N],top=0;
void add(int u,int v)
{
    edge[top].u =u;
    edge[top].v =v;
    edge[top].next =head[u];
    head[u]=top++;
    inde[v]++;
}
void topo()
{
    int i,j,t=0,k=0,s;
    queue<int>Q;
    for(i=0;i<n;i++)
     {
         if(inde[i]==0)//入度为零入队 
         {
             Q.push(i); 
        }
     }
     while(!Q.empty() )
     {
         t=Q.front() ;
         Q.pop() ;
         inde[t]=-1;
         k++;//记录入队人数 
         for(i=head[t];i!=-1;i=edge[i].next )
         {
              s=edge[i].v ;
             inde[s]--;
             if(inde[s]==0)
             Q.push(s); 
        }
     }
     if(k<n)//判断是否有环 
     printf("Yes\n");
     else
     printf("No\n");
}
int main()

{  
    int i,j,u,v=1;
    scanf("%d",&m);
    while(m--)
    {
        top=0;
        memset(inde,0,sizeof(inde));
        memset(head,-1,sizeof(head));
        scanf("%d",&n);
         getchar();
         char a[N];
         for(i=0;i<n;i++)//必须用字符串,直接取数字超时 
          {
              scanf("%s",a);
              for(j=0;j<n;j++)
               {
                   if(a[j]=='1')
                   add(i,j);
               }
          }
          printf("Case #%d: ",v++);
            topo();
            
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj 4324 Triangle LOVE

标签:triangle love   hdoj 4324   拓扑排序超时   拓扑排序   

原文地址:http://blog.csdn.net/zhangxiaoxiang123/article/details/47988581

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!