码迷,mamicode.com
首页 > 其他好文 > 详细

Cube Stacking

时间:2015-08-26 01:56:28      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M‘ for a move operation or a ‘C‘ for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2


题解:带权并查集。想要知道一个节点下面有多少个,可以用该节点所在集合的总个数 - 该节点上面的个数 - 自身(就是1)。用up保存上面的数量,sum保存一个集合的总数量就行了。如果不画图理解的话很困难,动手才是硬道理啊。


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int pre[300005]; //保存前驱 
int up[300005];  //该点的上面总共的个数 
int sum[300005]; //该集合的总个数 

int find(int x)
{
	if(x == pre[x]) //根上面没有节点了,up也不需要更新 
	{
		return x;
	}
	int fa = pre[x];  
	pre[x] = find(pre[x]);
	up[x] += up[fa];  //该节点上面的个数等于以前上面的个数加上父节点上面的个数 (父节点保存在以前中)
	
	return pre[x];
}

int main()
{
	int n;
	while(scanf("%d",&n) != EOF)
	{
		for(int i = 0;i <= n;i++)
		{
			pre[i] = i;
			up[i] = 0;
			sum[i] = 1;
		}
		char s[10];
		int x,y;
		for(int i = 0;i < n;i++)
		{
			scanf("%s",s);
			if(s[0] == 'M')
			{
				scanf("%d%d",&x,&y);
			    int l = find(x);  //找到跟,随你便更新了x集合的up 
				int r = find(y);
				if(l != r)    //不在同一个集合 
				{
				    pre[r] = l;  //合并 
					up[r] += sum[l];  //y的集合的up增加x集合的数量 
					sum[l] += sum[r];//x集合数量增加,y集合变成了x集合 
				}	
			} 
			else
			{
				scanf("%d",&x);
				y = find(x);//此时x可能没有更新up,再说我也需要知道x集合的数量. 
				printf("%d\n",sum[y] - up[x] - 1);//去掉自己 
			}
		}
	}
	
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Cube Stacking

标签:

原文地址:http://blog.csdn.net/wang2534499/article/details/47988693

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!