码迷,mamicode.com
首页 > 其他好文 > 详细

ACdream 1213 Matrix Multiplication【水题 、 找规律】

时间:2015-08-26 12:03:54      阅读:104      评论:0      收藏:0      [点我收藏+]

标签:

Matrix Multiplication

Time Limit: 2000/1000MS (Java/Others) Memory Limit: 128000/64000KB (Java/Others)

Problem Description

      Let us consider undirected graph G = {V; E} which has N vertices and M edges. Incidence matrix of this graph is N × M matrix A = {ai,j}, such that ai,j is 1 if i-th vertex is one of the ends of j -th edge and 0 in the other case. Your task is to find the sum of all elements of the matrix ATA.

Input

      The first line of the input file contains two integer numbers — N and M (2 ≤ N ≤ 10 000, 1 ≤ M ≤100 000). Then 2*M integer numbers follow, forming M pairs, each pair describes one edge of the graph. All edges are different and there are no loops (i.e. edge ends are distinct).

Output

      Output the only number — the sum requested.

Sample Input

4 4
1 2
1 3
2 3
2 4

Sample Output

18

水题。找规律,规律出来,题就解决了。
#include <cmath>
#include <queue>
#include <vector>
#include <cstdio>
#include <string>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <algorithm>
using namespace std;
//#pragma comment(linker, "/STACK:1024000000,1024000000")
#define FIN             freopen("input.txt","r",stdin)
#define FOUT            freopen("output.txt","w",stdout)
#define CASE(T)         for(scanf("%d",&T);T--;)
typedef long long LL;
const int maxn = 10000 + 5;
int N, M, cnt[maxn];
int main()
{
//    FIN;
    int a, b;
    while(~scanf("%d %d", &N, &M))
    {
        memset(cnt, 0, sizeof(cnt));
        for(int i = 1; i <= M; i++)
        {
            scanf("%d %d", &a, &b);
            cnt[a]++, cnt[b]++;
        }
        LL ans = 0;
        for(int i = 1; i <= N; i++)
        {
            ans += (LL)(cnt[i] * (cnt[i] - 1) / 2);
        }
        ans *= 2;
        ans += 2 * M;
        printf("%lld\n", ans);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

ACdream 1213 Matrix Multiplication【水题 、 找规律】

标签:

原文地址:http://blog.csdn.net/acmore_xiong/article/details/48000989

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!