码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 2602 Bone Collector 【01背包】

时间:2015-08-26 18:01:56      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 40289    Accepted Submission(s): 16736


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
技术分享

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
 
代码:
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int sum[1010];
int value[1010];
int volume[1010];
int main()
{
	int t;
	int n,v;
	int i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&v);
		for(i=0;i<n;i++)
		{
			scanf("%d",&value[i]);
		}
		for(i=0;i<n;i++)
		{
			scanf("%d",&volume[i]);
		}
		memset(sum,0,sizeof(sum));
		for(i=0;i<n;i++)
		{
			for(j=v;j>=volume[i];j--)
			{
				sum[j]=max(sum[j],sum[j-volume[i]]+value[i]);
			}
		}
		printf("%d\n",sum[v]);
	}
    return 0;
} 

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj 2602 Bone Collector 【01背包】

标签:

原文地址:http://blog.csdn.net/longge33445/article/details/48005621

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!