码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 2297 Survival 状压dp

时间:2015-08-26 22:39:17      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:

Description
The King of Fighter 97 (KOF97) is an electronic game of wrestling type. Once it was fashionable among youths. The game is amused. However, playing by oneself is not as excited as with friends. Getting bored? Maybe you can alter to the survival mode.

In the survival mode, you play as usual, but under quite unfair conditions: you must use your only character to beat all the other characters and Orichi as well (who is the BOSS)!!! How can you do that? We know that usually we will consume some HP of the character to beat one opponent. Although the character will recover some HP after beating one opponent, the amount of HP recovered is affected by the time you used, so it??s possible that the character lose some HP after one round. What??s worse, if the HP of your character is not enough for you to beat your opponent, you lose!

Given the HP of your character you need to consume and the HP your character will recover if you win for every opponent, you are to determine whether you can clear the game.

NOTE:
1. The initial HP of your character is 100.
2. You can challenge your opponents in any order except that Orichi is always the last one.
3. If your HP falls BELOW zero after any fights (before recovery), you will get your mission failed. 4. Your HP should never exceed 100.

Input

There are multiple test cases, which are separated by a blank line. The first line of each test case is a single integer N (1 <= N <= 20), gives the number of opponents you need to beat. The following N ?C 1 lines each contain two integers C and R (0 <= C, R <= 100), where C for the HP you need to consume to beat the opponent and R for the HP recovered after you beat the opponent. The last line contains only one integer P (0 <= P <= 100), describing the HP you need to consume to beat Orichi.

Output

For each test case, generate one line of output: if you can clear the game, print “clear!!!” otherwise print “try again” (both without quotations).

Sample Input

3
50 50
40 40
70

Sample Output

clear!!!

打怪,打死一个小怪要掉a的血,打死后可恢复b的血。。最后打boss,要掉m的血,,,血不能多于100,低于0就死了。。。问能不能活着打死boss。。。(先全部打死小怪,在打boss)

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<stack>
#pragma comment(linker,"/STACK:102400000,102400000")
#define pi acos(-1.0)
#define EPS 1e-6
#define INF (1<<24)
using namespace std;

int dp[1<<21];
struct UGLY{
    int lose;
    int get;
}ugly[22];
int boss;

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int i,j;
        for(i=1;i<n;i++) scanf("%d %d",&ugly[i].lose,&ugly[i].get);
        scanf("%d",&boss);

        int zhuang=(1<<(n-1))-1;//2^n-1

        memset(dp,0,sizeof(dp));
        dp[0]=100;

        for(i=0;i<=zhuang;i++)
        for(j=1;j<n;j++)
        {
            int k=1<<(j-1);
            if(!(i&k)&&dp[i]>=ugly[j].lose) //没有第j个怪的状态,并且这个时候的血够打死j怪
            {
                dp[i+k]=max(dp[i+k],dp[i]-ugly[j].lose+ugly[j].get);
                if(dp[i+k]>100) dp[i+k]=100;
            }
        }
        if(dp[zhuang]>=boss) printf("clear!!!\n");
        else printf("try again\n");
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

zoj 2297 Survival 状压dp

标签:

原文地址:http://blog.csdn.net/xtulollipop/article/details/48009303

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!