码迷,mamicode.com
首页 > 其他好文 > 详细

D广搜

时间:2014-07-13 13:51:23      阅读:223      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   2014   art   

<span style="color:#330099;">/*
D - 广搜 基础
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
Description
Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 


Input
The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Output
For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.
Sample Input
3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1
Sample Output
5
28
0
By Grant Yuan
2014.7.12
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<queue>
using namespace std;
//char a[9]={'0','a','b','c','d','e','f','g','h'};
//char b[9]={'0','1','2','3','4','5','6','7','8'};
bool flag[302][302];
int next[8][2]={1,2,2,1,-1,2,2,-1,-2,-1,-1,-2,-2,1,1,-2};
//char s1[5],s2[2];
//char s[10];
int x1,x2,y1,y2;
//int best=100;
int res;
typedef struct{
  int x;
  int y;
  int sum;
}node;
node q[100000];
int t;
int l;
bool can(int x,int y)
{
    if(x<l&&x>=0&&y<l&&y>=0&&flag[x][y]==0)
      return 1;
    return 0;
}
int ree;
int top,base;
void slove()
{int xx,yy,count,m,n;
     node q1;

    while(top>=base){
        if(q[base].x==x2&&q[base].y==y2){
            ree=q[base].sum;
            break;
            }

      else{
          m=q[base].x;
        n=q[base].y;
        count=q[base].sum;
        for(int i=0;i<8;i++)
          { xx=m+next[i][0];
            yy=n+next[i][1];
            if(can(xx,yy)){
               // cout<<xx<<" "<<yy<<endl;
                flag[xx][yy]=1;
                 q[++top].x=xx;
                 q[top].y=yy;
                 q[top].sum=count+1;              }
        }
        }base++;
      }
}

int main()
{node q1;
cin>>t;
   while(t--){
      cin>>l;
      cin>>x1>>y1;
      cin>>x2>>y2;
       //s1[2]='\0';
     //  puts(s1);
       top=-1;base=0;
       memset(flag,0,sizeof(flag));
         flag[x1][y1]=1;
         q[++top].x=x1;
         q[top].y=y1;
         q[top].sum=0;
        slove();
        printf("%d\n",ree);
       }
        return 0;

}
</span>

D广搜,布布扣,bubuko.com

D广搜

标签:des   style   color   os   2014   art   

原文地址:http://blog.csdn.net/yuanchang_best/article/details/37730517

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!