标签:
http://poj.org/problem?id=1988
Description
Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.
Write a program that can verify the results of the game.
Input
* Line 1: A single integer, P
* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M‘ for a move operation or a ‘C‘ for a count operation. For move operations, the line also contains two integers: X and Y.For
count operations, the line also contains a single integer: X.
Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
Output
Print the output from each of the count operations in the same order as the input file.
Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output
1
0
2
求出任何一个节点的下属的个数
/*
带权并查集,一堆中最顶上的方块作为父节点,用dis[X] 统计X到父亲节点的距离,num[fa[X]]表示团的大小,两者相减即为答案
*/
#include <stdio.h>
#include <string.h>
#define N 30000+100//结点个数
int num[N];//记录这个团队的人数
int dis[N];//记录有个点到根节点的距离
int per[N];//表示父节点
void init()
{
for(int i=0;i<N;++i)
{
num[i]=1;
dis[i]=0;
per[i]=i;
}
}
int find(int x)
{
if(x==per[x]) return x;
int t=per[x];
per[x]=find(per[x]);
dis[x]+=dis[t];//当查找一个数时,
return per[x];
}
void join(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
{
per[fy]=fx;
dis[fy]=num[fx];
num[fx]+=num[fy];
}
}
int main()
{
int n;
int a,b;
char ch;
while(~scanf("%d",&n))
{
init();
while(n--)
{
getchar();
scanf("%c",&ch);
if(ch=='M')
{
scanf("%d%d",&a,&b);
join(a,b);
}
else if(ch=='C')
{
scanf("%d",&a);
int x=find(a);
printf("%d\n",num[x]-dis[a]-1);
}
}
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
Cube Stacking POJ1988 【并查集的应用】
标签:
原文地址:http://blog.csdn.net/yuzhiwei1995/article/details/48022905