码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2533 最长上升子序列

时间:2015-08-27 16:42:39      阅读:114      评论:0      收藏:0      [点我收藏+]

标签:span idtransmarkspan

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 39374   Accepted: 17315

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>

using namespace std;

int a[10000];
int dp[10000];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            for(int j=i-1; j>=1; j--)
            {
                if(a[i]>a[j])
                {
			<span id="transmark"></span>dp[i]=max(dp[i],dp[j]+1);
                }
            }
        }
        int Max=-1;
        for(int i=1;i<=n;i++) //不一定dp[n]最大
			if(Max<dp[i])
				Max=dp[i];
        printf("%d\n",Max+1);
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 2533 最长上升子序列

标签:span idtransmarkspan

原文地址:http://blog.csdn.net/became_a_wolf/article/details/48029057

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!