码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1009 FatMouse' Trade(贪心)

时间:2015-08-27 18:38:40      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:

题目来源:hdu 1009 FatMouse’ Trade

FatMouse’ Trade
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54581 Accepted Submission(s): 18299

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output
13.333
31.500
题目大意:
输入m,n,m可以看做总容量,n组数据,每组数据输入J、F;J可看做该物品的总价值,F可看做该物品所占空间为F。所求的是m空间所能装的最大价值是多少,保留三位小数。
题目分析:
此题意在考查贪心思想,想要获得最大价值,我们就要首先取单位价值最大的,将其取完或者取满空间,若空间较大,则再取剩余的单位价值最大的物品。由此可知,此题需要对物品的单位价值进行排序,即(J/F)值,然后使用贪心即可。
AC代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
struct node{        //用结构体存放该物品的价值、体积、单位价值 
    int j,f;
    double v;
};
node edge[1010];
int cmp(node a,node b)  //对物品的单位价值从大到小进行排序 
{
    return a.v>b.v;
}
int main()
{
    int m,n;
    while(scanf("%d%d",&m,&n)!=EOF&&m!=-1&&n!=-1)
    {
        for(int i=0;i<n;i++)            //输入每件物品的价值及体积,并计算单位体积 
        {
            scanf("%d%d",&edge[i].j,&edge[i].f);
            edge[i].v=(double)edge[i].j/edge[i].f;
        }
        sort(edge,edge+n,cmp);  //进行排序 
        double ans=0;           //用来计算最大总价值 
        for(int i=0;i<n;i++)
        {
            if(m>=edge[i].f)    //若空间较大,则取完此物品,剩余空间为m减去该物品的体积 
            {
                m-=edge[i].f;   
                ans+=edge[i].j; //ans计算当前所取的最大价值 
            }
            else
            {
                ans+=edge[i].v*m;   //空间不足以装完此物品时,就装满剩余空间 
                break;              //此时所装价值为单位价值与所装空间之积,已无法继续装,故跳出 
            }
        }
        printf("%.3lf\n",ans);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 1009 FatMouse' Trade(贪心)

标签:

原文地址:http://blog.csdn.net/lsgbb/article/details/48031401

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!