码迷,mamicode.com
首页 > 其他好文 > 详细

杭电2824--The Euler function(欧拉函数)

时间:2015-08-27 21:10:28      阅读:112      评论:0      收藏:0      [点我收藏+]

标签:

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4559    Accepted Submission(s): 1902


Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 

 

Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 

 

Output
Output the result of (a)+ (a+1)+....+ (b)
 

 

Sample Input
3 100
 

 

Sample Output
3042
 

 

Source
 

 

Recommend
gaojie   |   We have carefully selected several similar problems for you:  2818 2825 2817 2822 2821
 
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int N = 3000010;
int prime[N], isprime[N];
int phi[N];
void Get_phi()
{
    int i, j, cnt = 0;
    for(i = 2; i < N; i++){
        if(isprime[i] == 0){
            prime[cnt++] = i;
            phi[i] = i-1;
        }    
        for(j = 0; j < cnt && i*prime[j] < N; j++){
            isprime[i*prime[j]]=1;
            if(i%prime[j]==0)
                phi[i*prime[j]]=phi[i]*prime[j];
            else
                phi[i*prime[j]]=phi[i]*(prime[j]-1);
        }
     }     
}  
int main()
{
    int a, b;
    Get_phi();
    while(~scanf("%d %d", &a, &b))
    {
        long long sum = 0;
        for(int i = a; i <= b; i++)
            sum += phi[i];
        cout << sum << endl;
    }
    return 0;
}

 

 

杭电2824--The Euler function(欧拉函数)

标签:

原文地址:http://www.cnblogs.com/fengshun/p/4764321.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!