码迷,mamicode.com
首页 > 其他好文 > 详细

Poj2377--Bad Cowtractors(最大生成树)

时间:2015-08-27 22:44:03      阅读:242      评论:0      收藏:0      [点我收藏+]

标签:

Bad Cowtractors
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12058   Accepted: 5008

Description

Bessie has been hired to build a cheap internet network among Farmer John‘s N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn‘t even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

Hint

OUTPUT DETAILS:

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

Source

最小生成树变形, 求最大生成树。 知识掌握不扎实, Wnm, 晕到权值都初始化为负值了,还处理成INF, 智商捉急啊。 Kl 比较好想。
Prim ac:
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int INF = 0x3f3f3f3f; 
int map[1010][1010], dis[1010], vis[1010];
int n, m;
void Prim()
{
    int TotalMon = 0;
    memset(vis, 0, sizeof(vis));
    for(int i = 1; i <= n; i++)
        dis[i] = map[1][i];
    vis[1] = 1; 
    for(int i = 1; i < n; i++){
        int temp = 1, max = 0;
        for(int j = 1; j <= n; j++)
        {
            if(!vis[j] && dis[j] > max)
            {
                temp = j;
                max = dis[j];    
            }    
        }
        if(max == 0){
            printf("-1\n");
            return;
        }
        TotalMon += max;
        vis[temp] = 1;
        for(int j = 1; j <= n; j++)
            if(!vis[j] && dis[j] < map[temp][j] && map[temp][j] != INF)
                dis[j] = map[temp][j];
            
    }    
    printf("%d\n", TotalMon);
} 
int main()
{
    while(~scanf("%d %d", &n, &m))
    {
        int u, v, w;
        memset(map, -1, sizeof(map));       //权值初始化为负;
        for(int i = 0; i < m; i++){
            scanf("%d %d %d", &u, &v, &w); 
            if(map[u][v] < w)
                map[u][v] = map[v][u] = w;
        }
        Prim();
    }
    return 0;
}

 

Poj2377--Bad Cowtractors(最大生成树)

标签:

原文地址:http://www.cnblogs.com/fengshun/p/4764731.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!