码迷,mamicode.com
首页 > 其他好文 > 详细

nyoj 94 cigarettes 【水题】

时间:2015-08-28 13:26:48      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:

cigarettes

时间限制:3000 ms  |  内存限制:65535 KB
难度:2
描述

Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.
Now,do you know how many cigarettes can Tom has?

输入
First input is a single line,it‘s n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
输出
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
样例输入
3
4 3
10 3
100 5
样例输出
5
14
124
来源
[rooot]原创
上传者
rooot
 
题意:
           输入一个数T,代表测试样例的个数,然后每个测试样例输入两个数n,k;n代表刚开始有n根香烟,k代表每k根烟头能够形成1根香烟,最终让求他能够吸多少根香烟!

           思路:

                     因为每一根新烟都会产生1根烟头(就算是他又新拼接的新烟也是如此),所以要用刚开始的n根新烟加上n根烟头所能产生的新烟的个数,这n根烟头产生的新烟重新被吸之后还要产生烟头,所以要重新加到烟头的总数上面,然后再进行组装新烟,具体看代码:

 

//这一道题的题意比较难理解,理解题意后就非常简单了! 
#include <stdio.h>
#include <string.h>
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n,k;
		scanf("%d%d",&n,&k);//n代表开始的时候有n根烟!k代表有k根烟头的话就能够形成一根新烟! 
		int t=0;
		int N=n;
		while(n)
		{
			n-=k;
			if(n<0)//应该是<不是<=; 
				break;
			t++;
			n++;
		}
		printf("%d\n",N+t);
	}
	return 0;
}
//通过特殊样例得到正确结果:输入:9 3;输出13; 


 

 

     

版权声明:本文为博主原创文章,未经博主允许不得转载。

nyoj 94 cigarettes 【水题】

标签:

原文地址:http://blog.csdn.net/dxx_111/article/details/48049149

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!